No Kodi menu click sounds and audio after playback stops

Hi colleagues :slight_smile:

I have an odd behaviour with OSMC with Kodi 19.1 on my rpi3.
Right after booting up, sound is working fine. Kodi menu click sounds are there, I can stream and hear music via raspotify and I can start movies and audio with passthrough is working just fine.
But once I started a movie playback and then stop/end the playback, there is no more sound… no menu click sounds, I can no longer hear music streamed via raspotify. If I start another movie, audio is working fine again, with passthrough. But when I stop it again, no audio… :confused:

What I tried:

  • in the settings → system → audio menu changing eg the feature “keep audio device active” restores audio directly, right afterwards click sounds are back, raspotify playback works (but just until next movie playback ends). I tried off, 1min, 2min, always
  • settings → system → audio → enable/disable output inaudible signal makes no difference
  • as I read something regarding joystick and controller support interfering with this audio stuff, I deactivated drivers and peripherals for joystick, mouse and controllers, but with no effect

Any further ideas? It is not that I couldnt live without those click sounds, but also other audio output (except movie playback) doesnt work. So would make sense to get this fixed :wink:
It is a fresh Kodi 19.1 on OSMC install, my old OSMC with latest Kodi 18 works normal without this bug. It is the same hardware, just a new SD card.

To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

Depending on the used skin you have to set the settings-level to standard or higher, in summary:

  • enable debug logging at settings->system->logging

  • reboot the OSMC device twice(!)

  • reproduce the issue

  • upload the log set (all configs and logs!) either using the Log Uploader method within the My OSMC menu in the GUI or the ssh method invoking command grab-logs -A

  • publish the provided URL from the log set upload, here

Thanks for your understanding. We hope that we can help you get up and running again shortly.

OSMC skin screenshot:

Hi, here is the log:

I did:

  • 2x reboot
  • clicking in gui, with sound
  • starting a movie and stop it after some seconds
  • clicking in gui, no more audio
  • entering menu settings → system → audio and toggled Output inaudible audio signal (Unhörbares Uadio Signal ausgeben) to re-enable audio and sounds
  • stopped debug logging

As I wrote in first post, if I start another movie playback, I get normal sound from movie, but afterwards still no sounds on the menu or elsewhere

Unfortunately there are no readable audio capabilities of the connected HDMI device in the logs but the first thing I suggest to change is to set GUI → settings → system → audio → output configuration → best match instead of optimized.

Hm ok will give that a try and report.
Are those capabilities missing because I am using a HDMI splitter at the moment to work around another issue (Problem with projector and spontanous black screens after using Kodi 19.1 - #3 by morti)?

When I press the return button on my remote while playing a videofile I dont get any menu sounds either. Not until I actually press the stop button. That might help you too.

While playback is running no menu sounds are played,I set that in the audio settings, actually it is also default. But my problem arises onve I stop the playback, so not pause, but really stop the playback and close the movie.

Probably not. The log-uploader is not getting the info. This has been fixed and will be in the next release update.

Switching to that setting doesnt change the behaviour :frowning:

FWIW, I don’t get any GUI sounds at all. Unless I keep audio device alive.

1 Like

I also do have this activated, yes.

Still existent on my RPi3… but I just tried it with a new RPi4 and Kodi 19.1 on OSMC and with my old kodi installation from RPI3 and issue doesnt appear on RPi4…