No longer able to connect to NAS

Hi there, after moving house I had my NAS out for months. When reconnected to my local network I found it is using another IP address (ending on .40 iso .22). I tried to put in a new location in OSMC but the system refuses to accept it. I get stuck in two screens where it asks either the location or the name. So I added as name: MijnVideos and as location
smb://userid:password@ but it will not accept it. What to do next?

So you were using Kodi smb paths before and then your subnet changed and so your trying to just change the ip address in your source location to fix the issue? If so I would suggest to change your source back to what it was before and then change your subnet in your router followed by rebooting your NAS and other devices. If this is not an option then the next best thing would be to use path substitution to repair the paths…

Thank you for your suggestions. I have still a problem. Using the interface via an attached keyboard to the PI 3b+ I was able to enter the new source location , but I get stuck between two screens. One asks for a name of the source, i.e. “mijn videos on NAS”, and than it asks for the ‘path’ which I enter as follows:
" smb://usename:password@ " (ignore the quotes) and then it goes back the the previous screen where it asks for a name which is then changed into the PATH I just entered. No error message or anything like cannot connect or whatever.

So I checked the sources.xml file via winscp and changed the existing entry to use the new IP address, but that does not work either. No option to remove wrong entries via the KODI interface either as they are grayed out. I’m disappointed that this seems to be such a difficult thing to resolve. On my PC I just removed the existing network shares and entered new ones with the new IP address and voila, everything works.

On top of that, I think I’ve made an error in the sources.xml file which is now probably useless. I cannot find a new ‘skeleton’ version, however. I checked the various WIKI items, but it simply states not to manually modify the sources.xml file. But how do I get back a ‘clean’ version than if the kodi interface is " unwilling" ?

The kodi interface is no longer showing the ‘add a new location’ so I cannot do anything.

LOL… does it? Thats funny. I guess whoever wrote that didn’t have a lot of confidence in people to understand a relatively simple file. You can edit it and you can swap it between a PC and Kodi running on any other platform as the format doesn’t change. Do note though, that sources.xml is only part of it and passwords.xml would need to checked and tweaked as well. When you setup a source to smb://usename:password@ kodi puts the path (ie smb:// in sources.xml AND it stores a path substitution from that path to the one that contains credentials. Therefore if your ip address changes then it needs to get updated in both to fix that source. BUT, the problem with fixing a path this way is that the sources set the location of where scraping happens only and when scraping Kodi stores full file paths. When you change a source location it does not update the paths in the library and you get dups and dead links. So if you are using a library and don’t want to make a mess of it the best thing is to not modify a source from what the current library has stored and instead just make a file that tells Kodi whenever you see the old ip address just go ahead and swap it out for the new one.