No Menu entries after October Update

Just updated 20 minutes ago.

Start screen now in grey, all texts disappeared, only OSMC logo on the top left hand corner.

I looks like all texts are now transparents :frowning_face:

How to fix ? i tried update / dist-upgrade though SSH and reboot => same result

The menus are rebuild after the reboot. It will display the empty screen for up to a minute. Did you waited for that to happen?

yes, i waited after reboot (now it makes 5 minutes), and no text …
I know that the system is “ready” because i can “navigate” in OSMC but without texts, i only see sometimes the white line moving when i push up or down in some menus (randomly selected)

I moved this to a new thread to make trouble shooting easier.
Suggest you upload logs so that the team can check if it sees any issues.

You might also want to try to move your Kodi folder to see if that fixes it (just for testing)

Let’s test with Kodi default settings. Enter the following commands with an SSH connection.

sudo systemctl stop mediacenter 
mv /home/osmc/.kodi /home/osmc/kodi.bak
sudo systemctl start mediacenter

If need you can restore:

sudo systemctl stop mediacenter
mv /home/osmc/kodi.bak /home/osmc/.kodi
sudo systemctl start mediacenter

Same result with Kodi default settings, i followed the commands you provided.

Logs available at

That’s really strange as that would indicate something wrong outside of the settings.
Let’s see if anyone else has an idea.

CC @Chillbo

I’m a bit stumped as well. I can see the osmc skin upgraded to the correct version and it is not loading old settings but there is a bunch of warnings displaying on the skin. Can you figure out how to change to the estuary skin with the display the way that it is to see if that skin displays correctly?

i stopped osmc :
sudo systemctl stop mediacenter

added new line in /home/osmc/.kodi/userdata/guisettings.xml to change skin:


then started osmc:
sudo systemctl start mediacenter

No change => still no menu, all grey with no textes
Reopened guisettings.xml => new line added dissapeared
-rw-r–r-- 1 osmc osmc 29K Nov 2 10:20 guisettings.xml

i noticed that, each time osmc is started with “sudo systemctl start mediacenter”, a new profile looks to be created, guisettings.xml has a new timestamp:
-rw-r–r-- 1 osmc osmc 29K Nov 2 10:25 guisettings.xml

This could be the result of a failing SD card.

To test this theory please reboot the Pi twice and run grab-logs -X. Then post the URL.

For testing just force it with an advancedsettings.xml file.

nano ~/.kodi/userdata/advancedsettings.xml

and put this inside

<advancedsettings version="1.0">
<setting id="">skin.estuary</setting>

Then ctrl-x, y, enter to save and then

sudo systemctl stop mediacenter
sudo systemctl start mediacenter

Hello Darwindesign,

Using a new file " advancedsettings.xml" as you wrote worked to get to GUI, Estuary is now launched and i can navigate in menus normally, but without all my customization (add-ons, network shares, …) but it’s normal for this test i suppose.

I reverted to the previous configuration to send logs as requested.

Please note that i deleted the file advancedsettings.xml used for the test with Darwindesign, i rebooted and the parameter skin.esturary was kept ! i found it in guisettings.xml (?) , so i changed it skin.osmc to get exactly the initial problem.

I rebooted twice

Logs available at

Please try this:

sudo apt-get install --reinstall mediacenter-skin-osmc

reboot and see if things improve.

When you did the the mv to kodi.bak that is what removed all your settings (which was the point) so we could quickly see if this was a profile issue. The advancedsettings command I gave forces a setting change and removes it from the GUI. When you then remove that from the advancedsettings file the setting is still changed but you will then be able to change the setting in the GUI again. My ‘for testing’ comment was just to say that this is not something that would be left under normal use.

Now that we know that the issue is isolated to just the OSMC skin hopefully running the command dillthedog posted above will get you back to working normal again.

Thank you dillthedog and darwindesign, it’s now working fine as before after the reinstall command.

Best Regards.