No more UPNP client after December Vero V update

I don’t have the time right now to do this debug but being a UPnP addon developer where I do view mapping and such against Kodi content types, I can confirm that when you browse a UPnP server the first entry point will be either a top or folders content type. We can’t tell if any others are impacted because if you can’t get past these you won’t get to the others like movie, episodes, musicvideos etc… further down the browse tree.

FYI, I just confirmed with Mezzmo that the entry point is top. That may be why Jellyfin is working for some folks if the issue is with top and folders is working. Jellyfin may present folders as the entry point.

Here’s a message I added to catch the initial content type in the Kodi log.

2023-12-24 12:31:57.367 T:17876 info : Content type is: top



Out of curiosity are you starting at the top of the tree at Video, Music and Photos or was this a favorite to music or video / media ? If the issue is just with the content type top then that is only seen at the UPnP root. Afterwards navigation is all folders until you get into a content folder and then it switches to the specific media type.



I’m quite sure that the content type “folders” and “top” don’t exist in Kodi’s skin engine :joy: But I can’t be absolutely sure before seeing a screenshot that has the content type printed in the top right corner… I’d like to get this this time, so it would be good to be sure :+1:t3:

From the limited documentation I could find, the content type mostly associated to upnp addons seems to be “unknown”.

Ok, it looks like top and folders content types are impacted. I changed the source pointer in Kodi to further down the UPnP tree where there were individual items like movies and folders combined. The individual movie items showed up, folders did not. Likewise top is broken too since when I point at the root nothing shows up and that is content type top.

and "yes’ I don’t see these content types documented in the Kodi docs. :smiley:



Well, then the issue would be that random content types not allowed or meant to be used are set:

The content types are meant to be limited to a sensible set defined by Kodi (which is kind of ironic due to the lack of documentation) so that skins can offer perfectly adjusted views for them. If you have any content type, this will never work - as we can see. Many skins just use content types in a very broad sense and thus the underlying issue doesn’t show.

Do the debug labels of the OSMC Skin truly show these content types you mentioned in the top right corner? :face_with_peeking_eye:

Ok, so I had a few minutes to do more testing.

Here’s what I am seeing with Confluence and Estuary:

Confluence UPnP root - top
Confluence UPnP folders - folders
Confluence UPnP items - movies

Estuary UPnP root - top
Estuary UPnP folders - top
Estuary UPnP items - movies

OSMC screenshot for root and folders:

OSMC screenshot of items:

This is one of the many reasons I chose not to do skinning and stick with coding. It would be nice if you could do top and maybe folders to match the other skins.


I checked a Vero V still running the July release. It also says Unknown content type for the root and folders but they display.



Ok, I have solved the mystery of the top and folder content types. The Mezzmo Kodi addon is setting those based upon the position in the UPnP tree. It’s been a few years since I worked on this section of code.

My apologies for the confusion. So it appears to be the unknown label that is causing the issue since that occurs outside of the addon in native Kodi UPnP browsing.



1 Like

Perfect, thank you for investigating! I’ll have a fix soon - will just have to see whether we can push this as a separate update just to get this single fix out… Will keep you posted :+1:t3:

Well I never used UPNP before so I just added a source for testing and then went from the top. But maybe as I added the source in either Videos or Music the window was labeled like that and the issue is just the “unknown” window type missing.


Hopefully the issue is now addressed with the following commit: Blank screen media window fix · osmc/skin.osmc@43aa49b · GitHub

I’d appreciate it if you could test this and provide feedback before we potentially release this as an update to other users. To test this update:

  1. Login via the command line
  2. Run the following command to add the staging repository:
    echo 'deb bullseye-devel main' | sudo tee /etc/apt/sources.list.d/osmc-devel.list
  3. Run the following commands to update: sudo apt-get update && sudo apt-get dist-upgrade && reboot
  4. Your system should have have received the update.

Please see if the issue is resolved.

I also recommend you remove /etc/apt/sources.list.d/osmc-devel.list after updating.

This will deactivate the staging repository. You can do so with the following command:
sudo rm /etc/apt/sources.list.d/osmc-devel.list.

Please note that we will automatically disable this update channel after 14 days on your device in case you forget to do so to ensure that your system reverts to the stable update channel.

1 Like

Apologies for the delay testing this. I followed the steps above and I can now browse Jellyfin, Mezzmo and Plex UPnP servers from their root entry points using the OSMC skin with no issues.



1 Like

I can also confirm that all listings are showing up as expected from my Gerbera source following adding the dev repo and upgrading. Looks like this one is fixed!

1 Like

Great to hear this! Thx for reporting back :+1:t3:

I assume this fix will now wait for the January release (other than for those of us who used the dev repo above).

Yes – it will be in the next OSMC update

1 Like

I recently allowed the December update through on my two Vero 4K+s and my Vero V. This was driving me crazy today until I found this forum post!!! Looking forward to the next OSMC update because I depend on UPnP to stream from one source to multiple TVs.


I followed Chillbo’s instructions above.

I logged in via ssh from Windows cmd prompt and ran the lines of code as instructed.
Vero V updated and restarted.
Now I can see the UPnP server directory and some BUT NOT ALL files.

There is still something wrong.
Some directories are empty even though they have video files (.mp4 and .mkv) in them.
Comparing to an unupgraded Vero 4K+, I can see the files that aren’t being seen on the upgraded Vero V even after Chillbo’s update.
It’s odd because some directories lead me to .mp4s and .mkvs that I can see, but others have a blank screen instead of showing the video files. I don’t really see much of a pattern.

Also: I can view the still missing files in the OSMC Skin with the Estuary Skin,

Unless I’m mistaken I think if you turn on the debug view in the OSMC skins settings and navigate to those views with the missing content (you can see the colored text overlays in the screenshots Jeff2 posted above) and post here what the labels are then @Chillbo may have the ability to rectify that.

Thank you for pointing that out @darwindesign
Pictures and details below for @Chillbo

Here is a random folder that used to be visible on the default OSMC Skin on UPnP, but now isn’t even after updating (with instructions No more UPNP client after December Vero V update - #54 by Chillbo).
Estuary shown at bottom to show that it isn’t UPnP, but the skin.
(sorry about the blue background making the blue text hard to see)

And to be clear, before the update no directory structure was coming up.
Now, what I believe is the full directory structure is visible, and some but not all folders are showing empty when they aren’t.

The items in this example folder are:
21 Jump Street (Cover).jpg
21 Jump Street (HD) (2012).mp4
21 Jump Street (HD) (2012).srt
21 Jump Street (Icon).jpg