No network after half an hour

Yesterday I installed OSMC RC3 to replace my Raspbmc installation. I looked through the menu’s and found the manual update functionality and hit enter to do so. After that I lost my network and couldn’t connect via ssh nor could I ping the device.
About half an hour ago, I re-installed RC3 of OSMC (without manual update) and started to configure everything the way I like (different hostname, database on MySQL and nfs mounts for my video’s) after a few reboots I found that I couldn’t connect via ssh anymore, nor could I acces my nfs mounts configured in kodi.

I made the following changes via ssh after installation and rebooted after every change:

  • Static IP address configured using installer --> everything worked
  • Changes to /etc/hostname and /etc/hosts to replace osmc --> everything worked
  • Added ~/.kodi/userdata/advancedsettings.xml --> everything worked
  • Added ~/.kodi/userdata/sources.xml --> No network

I am using a Raspberry Pi B, using the ethernet connection.
Looking to ‘ifconfig’, the settings are correct, but I can’t ping anywhere.

Any idea’s? If not what logfiles do you need? (bit hard to get without network support… but I will try ;))

There is nothing that sources.xml could do to cause your network connection to stop working, so this is either a co-incidence or the extra CPU load of Kodi trying to scan your sources is causing the voltage to drop, which can cause Ethernet/USB to fail.

The log uploader has the option to save the log files to the SD card :wink: So after reproducing the problem, use the log uploader to save ALL logs to the SD card, then shut down and put the SD card back in your PC and you’ll find a log file that you can upload to

If you have access to a voltmeter, measure the voltage between TP1 and TP2 when you’re seeing the problem - if it’s below 4.75v then that is most likely your problem.

I already doubted that it would have to do something with sources.xml, and I don’t believe it has to do with the extra CPU load of Kodi, since yesterday I didn’t even come this far.

Anyways, after posting this message, I moved sources.xml out of the settings folder, rebooted and had some lunch, after that I tried to connect again and it worked. Moving sources.xml back again, I rebooted, watch some tennis and tried again and it all worked.
Now I am happily running OSMC with Kodi.

Thanks anyway for the suggestions about the log files :wink:

Well, you still haven’t actually found the underlying problem, which I’m reasonably sure will be related to marginal power.

So when it happens again, please do investigate the power issue properly… :wink: