No network connection after upgrade

Hi, I think I did something stupid and updated osmc by apt-get and ssh doing update and then autoremove.
Probably something went wrong while the system was removing conn man osmc 1.2.6 (if I correctly remember): now when I fire up my pi2 I get to osmc but I do not have any network connection.
Going in my osmc the icon for connection manager is no more there.
I suppose I have to re-install some packages with dpkg -I but…I do not know which and where to download them.

Can someone help?

Happend same thing to did a upgrade thru gui, saw connman got an update lost network.

A reboot and then enable network in my osmc worked for me.


Obviously I tried to reboot and open my osmc but in my osmc the conn manager icon is no more presentt

Are you saying that the networking icon in OSMC settings is missing ?

It sounds like you don’t have connman installed at all - an upgrade won’t do that unless you have manually removed some other package that OSMC relies on.

Please download the following file:

Copy it onto your SD card from a PC, then after booting OSMC, press quit/exit then ESC then login with osmc/osmc

Now install connman from the file you copied to the SD card:

sudo dpkg -i /boot/armv7-connman-osmc_1.2.6_armhf.deb

Then try rebooting. Assuming that fixes your connection please use the log uploader to upload ALL your logs so we can do a post mortem on what went wrong…

Thanks, that is what I need I hope.
I am not at home thus I will go through this and let you know during the weekend.

Ok it seems I have more problems that what I thought.
Trying to do what you suggested but the system is complaining connman depends on libxtables10 which is not installed :frowning:

i finally set back my connection downloading libxtables10 from debian repository and installing it.
now i can connect to internet, run apt-get update and apt-get upgrade successfully.

in my OSMC connection manager icon is still not present though

You should always use dist-upgrade not upgrade when upgrading OSMC.

Can you upload your log files please ? It sounds like you may have un-installed a “required” package back before you did the upgrade, which can result in the rbp2-device-osmc package being un-installed which will in turn un-install other packages and leave your system in a bad state.

It is possible to recover from this without a full re-install but I would need to see your log files to confirm what went wrong to know the correct course of action. (And also help us see if there is a way this could be avoided in the future)

i tried but…it says “server not reachable” when i try to upload logs from myosmc

if i run

sudo apt-get install rbp2-device-osmc

it tries to install

 armv7-irqbalance-osmc armv7-network-osmc bluez busybox cifs-utils curl fake-hwclock iptables kmod libcurl3 libicu52 libnfnetlink0 libnl-3-200
  libnl-genl-3-200 libpsl0 module-init-tools nano net-tools python-dbus python-dbus-dev wget wireless-firmware-osmc wpasupplicant

which makes me guess it happened what you supposed, thus should i say yes and install?

Yes, as long as you have a Pi 2 you should go ahead and re-install rbp2-device-osmc. With all the above packages missing your system is severely broken, but this should fix that for you.

By the way the log upload can copy the log files to the SD card - instead of choosing “upload selected logs now”, choose “copy selected logs to sd card now” which will save a file called uploadlog.txt on your /boot FAT32 partition which you can access from a PC if you insert the SD card.

If you could try to do this and get your log uploaded before attempting to install rbp2-device-osmc that would help us see what went wrong.

yes i do have a Pi 2.
installed and it was complaining about iptables: i had to delete it from cache and re-download as apt-get was saying it was not in “.deb” format (???).
anyway all seems to work: i uploaded the log oxaheceque

but this was done after i re-installed everything.
is there a way to check that I have installed all packages i am supposed to?

by the way thanks for the support, i made a 10£ donation as i felt a so prompt support needs to be rewarded specially being an open source project

mmm ok it seems that not everything is still ok.
I use my RPi 2 with OSMC and as Transmission + Samba machine.

before this issue with same HW and SW setup (obviously SW has now some problems due to me :frowning:) i was able to transfer with speed up to 10Mb/s, now i can only reach 0.5Mb/s :frowning:

is there something i can do to fix this?

Are you on Ethernet or Wifi ?

I can’t really see how anything that has happened would affect your network speed, especially if you’re on Ethernet.

mmm i went more in depth and it seems no related to samba connection but to USB transfer speed.
I have in fact a USB disk connected to mi Rpi 2 through and external (powered) USB which so far led to very good performance.

After the issue i created is now extremely slow even when copying locally from the disk to a USB dongle drive: speed is like 0.5Mbyte/s which makes me suppose all the performance issue is related to that.

i tried to run fsck.ext4 but no problem spotted out.
I mount the disk with

/dev/sdb1       /home/osmc/USB_DISK     ext4    defaults,noatime,nofail 0       0

i start thinking this is not related to the issue i created by more to RC1 to RC2 update as i read something like that on the forum.
On the line above i tried to add “asynch” but without any improvements

starting to think RPi 2 connects to the drive with USB 1.0 instead of 2.0

i got this

osmc@osmc:/var/log$ sudo lsusb -t
/:  Bus 01.Port 1: Dev 1, Class=root_hub, Driver=dwc_otg/1p, 480M
    |__ Port 1: Dev 2, If 0, Class=Hub, Driver=hub/5p, 480M
        |__ Port 1: Dev 3, If 0, Class=Vendor Specific Class, Driver=smsc95xx, 480M
        |__ Port 2: Dev 4, If 0, Class=Hub, Driver=hub/4p, 12M
            |__ Port 1: Dev 6, If 0, Class=Hub, Driver=hub/4p, 12M
            |__ Port 4: Dev 8, If 0, Class=Mass Storage, Driver=usb-storage, 12M
        |__ Port 4: Dev 5, If 0, Class=Mass Storage, Driver=usb-storage, 480M

i have connected a USB stick (USB install which peforms as expected) directly to RPi 2 and a hub connected to RPi 2 with a HD connected
the problem is i can’t decode what is written above

Can you try a fresh install on a spare SD card and test the USB speed and check USB modes with lsusb on the test installation ?

Just ordered a spare micro sd card on Amazon as I have only 1 available :frowning:
I will do some test next weekend while tomorrow I will try to connect a second usb hub just in case it is this failing

i just swapped the USB hub with a different one and now my HDD is back to full speed USB 2.0.
it could just be a coincidence that my hub gave up at the same time i shit the system :-1: although this looks a very strange coincidence to me.

let’s see how stable will be the situation now