No network connection since installing Kodi 20.1

Hi - just installed latest version, & I can’t access any of my Windows 10 folders (SMB), using wired ethernet. Trying to browse, all show either connection timed out or invalid.

Any clues please?

Hard to say with no relevant details or logs…

To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

Depending on the used skin you have to set the settings-level to standard or higher, in summary:

  • enable debug logging at settings->system->logging

  • reboot the OSMC device twice(!)

  • reproduce the issue

  • upload the log set (all configs and logs!) either using the Log Uploader method within the My OSMC menu in the GUI or the ssh method invoking command grab-logs -A

  • publish the provided URL from the log set upload, here

Thanks for your understanding. We hope that we can help you get up and running again shortly.

OSMC skin screenshot:

ok, 1st time for doing this, so hope it’s ok…


Is it only smb://Acer-mb with the issue? Do the sources using IP addresses still work? If so I would check and see if you can connect to that source if you use an IP address and if so I would just add a path substitution to swap the name for the number.

unfortunately both are failing, ie IP or name.

Is Acer-mb and the same Win10 PC? Was this something you setup using SMBv1 (ie guest access, no password)? Have you tried ssh’ing into your Vero and doing a ping back to this PC?

yes, same machine. No, can you explain how I do the SSH into the Vero, & I could try that?

More complete instructions [here] but short form for you assuming you didn’t disable ssh during first boot and are using default passwords would be to click on the start menu in Windows, type in “cmd” and hit enter, then type in…
ssh osmc@
and then enter the password “osmc” and assuming it dropped you into the terminal and you typed yes and enter for the security question you would then type…
It should start dropping lines for a bunch of responses without errors about not being able to find the network location. You can ctrl+c to stop ping and exit to close the terminal session and return to cmd.

Hi - thanks for this. I found that I wasn’t seeing the network folders on a laptop either. I changed the SMB client setting to ON in Windows features, & rebooted the PC.

All seems ok now, so hopefully that was root cause (although don’t understand how it could have changed).

thanks for your help, at least now I know how to raise a problem & post a log file.

1 Like