No option for E-AC3 passthrough, resampling stops playback

I’ve just switched to a Raspberry Pi 4 4GB after years running OSMC on a Pi3B. Playing video files that use Dolby Digital Plus / E-AC3 results in no sound and after approx 5 seconds the playback stutters and stops. The picture remains still, it hasn’t crashed, and I can press Stop, or skip through the video which then plays another 5 seconds before stopping.

Through various posts here, this seems to be due to problems resampling the audio. The Pi is connected using official Raspberry Pi HDMI to a Sony amp that supports DD/DDP/DTS (STR-DA3500ES). I have audio in Kodi set to 7.1 and allow passthrough (sync to display is disabled, stereo upmix is disabled). So for AC3 streams this works perfectly.

The difference I find with the Pi4 is the option to enable passthrough for E-AC3 is missing from the GUI. This is available on the Pi3 and enabled (OSMC with Kodi v18).

I saw on this thread that “HD audio” support was pulled from the Pi until Bullseye. I’m not sure if “HD audio” there includes E-AC3, This is a new OSMC install on a Pi4, running the latest May 23 release from the installer, with no updates available.

I’ve uploaded logs which show playing a file with AC3 that uses passthrough at 2023-05-26 09:12:08.462. I then tried a file using E-AC3 and you can see the errors at 2023-05-26 09:12:30.145

I can mitigate the issue by changing the speaker config option to 2.0 with passthrough still enabled for AC3 and DTS only, but I would like to be able to use the receiver’s support for E-AC3 rather than downgrading these streams to 2.0.


Which HDMI port of the Pi are you using?

It’s plugged to what I believe is #1, the nearest to the USB-C power.

That should be HDMI 0, so that is correct

@candm In the GUI->settings->system->audio menu, you’ve to change the audio output device (on top of the menu) from ‘MAI PCM i2s-hifi’ to last item of the displayed list ‘SNY SONY AVAMP on HDMI’ … and you need to restart the system.

Believing the STR-DA3500ES manual, the AVR supports ALL passthrough options of the mediacenter.

Important addition: I’ve now fallen into the same trap even with the right output device set. After restart of the RPi4, I’m only presented with a few passthrough options.
Workaound here:

  • Shut down the RPi4
  • turn off the AVR (!!!)
  • reboot the RPi4 (power off and on again)
  • … and then wait 2-3 minutes before turning the AVR back on.
  • make your passthrough options configuration

This worked, with the addition of rebooting again with the TV/AVR on, as there was no signal otherwise. Thank you so much! Sorry that it took a while to reply - been away last week so only just been able to try this.

My steps:

  • Changed audio device (first option under Settings > System > Audio) to the last option vc4hdmi0 SONY AVAMP. No change in behaviour at this point.
  • Turn off TV and AVR. Use SSH to reboot Pi.
  • Turn on TV and AVR. No HDMI signal to AVR.
  • Turn off TV and AVR. Use SSH to reboot Pi.
  • Turn on TV and AVR. No HDMI signal to AVR.
  • Use SSH to reboot Pi while TV and AVR on.
  • Audio settings now show the extra option for E-AC3. Enabling this and now Dolby Digital+ streams are passed through to the AVR, and there’a no video playback issues.

(The lack of signal on reboot I assume is due to boot config options; haven’t tested it yet. On the old Pi3 I had the option set to force HDMI, but haven’t altered any options on Pi4 (yet!), trying to keep it near-stock.)

Should audio in kodi not be set to 2.0 for passthrough.?