No option to connect to wifi

I’m using a canakit wifi adapter on raspberry pi 2, and as I reach the networking step of the setup, the only available options are “wired” and “MySQL” - why am I not seeing the option to connect to wifi?

The dongle is pushed all the way in but the led light is not lit. I plugged the wifi adapter in my PC and the led did light up. I’ve tried it in every usb port on my raspberry 2.

Any suggestions? Thanks,


Hi @stantonjones!

You haven’t informed about wich wifi adapter you are trying to use.

The most likely reason is that your RPi don’t support the wifi adapter you are trying to use.
Maybe it will be added later. But I also know from experience that it is possible (If you are a “linux ninja”) to “MODIFY” the driver to suit the distro…

The fastest way to get it working is to try a supported adapter instead.
I have successfully got it to work with both the “WiPi” which is the adapter from “element14” who created the RPi. This is the "The ORIGINAL"adapter.
I also have tried “TP-Link” (TL-WN821N) with success.