No Passthru Audio + Backup 'failure' + Various

Here are a few issues and questions, in order of importance. The first two have been an issue since updating to Kodi v19. Apologies for combining them here. I also realize some or all are Kodi issues rather than Vero/OSMC, but you guys are nicer and smarter. :slight_smile:


  1. Passthru audio periodically but frequently fails to work, without having changed any settings since Kodi v17 or so. No sound is output to receiver, but interface sounds can be heard. Discovered that if I change audio to 2.0 instead of 5.1 or turn off the AC3 capable receiver toggle (under passthru), I get audio output. If the audio is already 2.0 and it’s set to 5.1 and AC3 is on, it also works. I’m not sure if my (old) receiver actually supports AC3, but it always worked before with that AC3 toggle on and still sometimes seems to work with it on. So curious? All other settings under passthru are off. Should I maybe turn on DTS or other? (I can see some info in the logs related to this but can’t interpret: “Your hardware does not support AE_FMT_FLOAT”) The audio output to receiver goes over the HDMI. FWIW here’s the pioneer VSX-819H receiver specs with audio info.

  2. Getting regular (daily?) error messages about failing to copy the .TAR file to the backup location on the SDCard, with an error message complaining of insufficient memory. I cannot find anything corresponding in the log. However, current daily backups seem to be in the specified location on the card. (set to keep 3 backups, Each is ~1.5gb). Card is 32GB and those are by far the biggest files. Need to check but doubt card is even 25% full. Is there something to fix here? A way to surpress an inaccure error message?

  3. Q (out of curiousity): I was experiencing frequent crashes, and with log, tracked them down to 2 zipped subtitle files. When I moved these out of source folders, those crashes stopped. Why is Kodi even trying to read those files? What in them could cause a replicable crash?

  4. Q (related to above). Why is Kodi trying to access basically all the files in my library when browsing say, Movies? Or is it trying to back something up? I’m not playing these videos. Log is littered with messages like (what does that all mean?):
    CNFSFile::Open: Unable to open file …
    AddOnLog: vfs.rar: CRARControl::ArchiveList: failed to open …
    InputStream: Error opening, …

  5. Still getting more frequent crashes with Kodi v19 than before (or so it seems). Last one, was when I removed the last movie from a movie set and then went back to browse movies (when that set was then empty and therefore effectively deleted). Crashed at that point. Wonder if replicable?

  6. Accessing “myosmc” sometimes just fails with K19. Says cannot be accessed at this time or something. Try again later it works. Ideas?

Well, I would say that if your device runs out of memory, you will see lots of errors showing up in general.
Even the posted logfile is not complete.

Best bet is you go into your vero device and free up some space, then generate some new logs.
But I suppose that as soon as you provided space, it will work better already.

Thanks for your reply. What’s the capacity of of the Vero device? There’s nothing in particular on the Vero device. No media files or anything. The userdata folder is 3.1GB. There are 2.65 GB of thumbnails. Could that be an issue? Is the backup system trying to backup those thumbnails? Even if so, the backup target (the SD card) has plenty of space.

Still there are several other non-memory related issues here (esp the audio).

The eMMC is 16GB

Vero has more space. Suspect it to be a 16Gb drive with 14Gb available for the system etc/
Any chance you can go on it and make a: df -h /
here’s mine:

$ df -h /
Filesystem           Size  Used Avail Use% Mounted on
/dev/vero-nand/root   14G  6,0G  7,2G  46% /

Half full. So doesn’t seem like memory should be an issue.

Filesystem Size Used Avail Use% Mounted on
/dev/vero-nand/root 14G 6.9G 6.3G 53% /

Does the command “dmesg” show any mention of error at the end?
This is an indication for hardware error.
If there are none, I suspect a corrupt librarie/binary doing strange things.

1 Like

This message is repeated many times with the dmesg command.

[30699.917056] Mali: ERR: drivers/osmc/gpu/mali/linux/mali_memory_os_alloc.c
[30699.917065] mali_mem_os_alloc_pages() 230
alloc_page() return NULL! try again!

… so is that an indicaiton of a hardware error?

Can you post full debug logs please?

AIUI, that’s just Kodi digging up the info for the files listed on your screen.

Usually only happens just after an update. Is it happening more often?

1 Like

here you go, from the OSMC log uploader:

#1 Audio issue

Here I played “Afterlife” 3 times. first with AC3 passthru on (no audio) then with it off (audio plays) then with it off and DTS on (audio plays). So again, the question is why AC3 passthru on = no audio (when it worked previously)

#2 decompressing RAR / memory issue

I had the nature of this error wrong in OP. Apologies.
the error (which shows up in the KODI GUI as an alert) is actually:
'Not enough memory available to decompress file'
… and as you can see it occurs after “encountering” .rar files while apparently browsing movie library – which in turn relates to #4 above. Why is it attempting to decompress .rar files at all on a remote source on the LAN (volumes on my Mac)? And not enough memory for what? Maybe it has no write access (and it shouldn’t, right?)
[FWIW … there were 4 movies with an orphaned .rar file in its folder and I just trashed them all – guessing that will solve that problem, but still… again, why is it trying to decompress them at all?]

shouldn’t all of that have happened when it scraped them?

worked this time at least. maybe only then. thanks.

I don’t know, there’s nothing obvious in the log. But since your AVR supports every format under the sun, why not enable them all (DTS, DTS-HD, DD, DD+ and TrueHD)?

And even if you have a 5.1 speaker set, many people recommend setting Vero output to 7.1 and letting the AVR downmix to 5.1.

These settings may help.

You’d have thought. Maybe it checks to see nothing has changed?

1 Like

This is an indicator that the memory cannot be allocated. The reason, we don’t know yet.
What else is running on it? Device?

It’s a Vero 4K+ and AFAIK nothing else is running on it.

If you run a “top” - anything using up all resources? Can you post us a screenshot?
You can also paste the result of:

top -d 1 -n 1


looks pretty good to me… everything now shown is using 0% CPU / 0% MEM

Tasks: 180 total,   2 running, 177 sleeping,   0 stopped,   1 zombie
%Cpu(s):  9.0 us,  4.5 sy,  1.5 ni, 85.1 id,  0.0 wa,  0.0 hi,  0.0 si,  0.0 st
MiB Mem :   1989.5 total,    572.0 free,   1013.4 used,    404.1 buff/cache
MiB Swap:      0.0 total,      0.0 free,      0.0 used.    846.0 avail Mem 

  PID USER      PR  NI    VIRT    RES    SHR S  %CPU  %MEM     TIME+ COMMAND                                           
 2619 osmc      20   0 1720832 823124  21976 R  64.7  40.4   2276:05 kodi.bin                                          
12016 osmc      20   0    9692   2772   2216 R   5.9   0.1   0:00.04 top

Well, there is one zombie process, hence something is not working right. Usually you don’t have any.
And with your history of issues on the mem alloc in dmesg, I suspect, if no program causes that, that there is a hardware fault.

1 Like

hmmm… ok thanks. I already had to return the original Vero 4K+ I bought because of another hardware fault. That was some time ago though. I suppose I’ll just ride this out as long as it’s generally working otherwise.

That is weird. I have 4 Vero’s - and never had an issue on the hardware side.
Eventually check your power-supply, add a filter or so. Because if that happens often, something must be different IMHO.

For the audio issue, make sure the options “Maintain original volume on downmix” and “Stereo upmix” are not selected. I had weird issues with audio that were cured when these options were deselected.