No peripherals, loss of CEC ARC, forced input change

Found more issues with Vero.

Every time I power on my TV and surround sound, Vero is forcing my Onkyo amp to change input to itself.

I have tried accessing the ‘peripherals’ page within settings but the list is blank, nothing shows. I see the amp trying to refresh the audio connection when I access the page so something is happening but obviously Vero/Osmc cannot detect anything.

This may explain why CEC commands do not work. I’m using a different HDMI cable which I know works with CEC.

It’s really important to stop Vero grabbing input attention as it messes with my Logitech Harmony remote.

In addition to these issues, if power to Vero is removed but the HDMI cable still connected, it causes my entire setup to loose audio connection to my Onkyo amp. The sound reverts to the TV speakers for every device (not only Vero).

I believe it’s related to pin 13 and CEC as I read some Raspberry Pi’s caused the same problem. The solution was to break off a diode to allow CEC to work even if power to the device was cut.

I can power off my blu-ray, apple tv, firetv and leave the HDMI cables in and everything is fine. With Vero, it’s a different story.

Please advise?

It would be interesting if Vero suffered from the same issue as the early RPi models. Even with the D14 issue on the early RPi it only affected some people (mine never had a problem).
The best description of the RPi issue that I remember reading at the time is in this post

What Skin are you using ?

Some skins are not able to display the Peripherals page correctly (bug in the Skin) - for example I use Black Glass Nova and it does not display any entries in the Peripherals page, although oddly I can just press OK and get through to the CEC settings anyway…

Try changing Skin to Confluence so you can access the CEC settings, then turn off “make kodi the active source when starting”. This will prevent it switching sources when Kodi loads.

This is quite possibly driver related. At the moment the CEC interface on Vero is not exposed as shared. A shared mode driver may improve things.


I’ve tried osmc and confluence skins and issue remains.

Sam, you talk about driver issues and changing to shared mode but how does this help me? What’s the solution to the problem?


This is not a Vero related problem.
I’ve been having this issues with many (not all) HDMI sources that have not been plugged in the power outlet. I have everything connected through a Pioneer receiver via hdmi but i also have a sony soundbar between the TV and receiver connected. Once i pull the plug on one device my soundbar loses it’s cec connection to the tv.
Just keep everything plugged in is the best (and only??) solution.

I’m not so concerned keeping the power on, if that’s what is needed. I do need, however, to stop vero changing inputs on my amp. So what’s the solution if the peripherals page does not load?

Our shared mode driver is beneficial in that it will allow multiple applications to access the CEC bus at once (particularly useful when we add our web browser).

As my colleague @DBMandrake suggested, trying a different skin, even temporarily, may help here.

Sam, I replied earlier and said I had tried OSMC and Confluence skins. I now have eminence skin active and same issue. I cannot be anything related to the skin.

Please advise?

Can I edit a config file manually and turn the option off?


Have you run updates ? If so you should not be missing the CEC option when in confluence - please post your logs so we can figure out why.

yes, imx6 boards do suffer from this.

unpowered and (hdmi) attached board effectively disables CECbus communication.

Apologies for the slightly delay in replying. Have had a busy weekend.

I had all updates installed as of Friday night (24th April). Ran update check this morning and it appeared a few files installed but went through very quickly so couldn’t see the exact file names.

Tried the peripherals page again, and now I can see my Onkyo system. Changed the settings and it appears Kodi no longer forces my amp to change input. That’s great.

I assume an update had been released since Friday night?

In regards to the other issue, I am happy to keep the power on whilst the Vero has an HDMI cable attached.

Many thanks for the help.