No picture at all (after screen noise)

So after I had some network issues Sam kindly sent me a replacement Vero 4K+ although he could reproduce the issue only partially.

However, this unit seems to have more severe problems. I connected it to the same HDMI cable which worked fine with the Vero4K and the former Vero 4K+. I already got a bit of screen noise (white pixel patterns) while doing it which I attributed to having connected the HDMI cable after boot. I rebooted the Vero 4K+, got through the setup again (with black screen during setup twice for three seconds now) and then managed to get into Kodi.

Here I was able to set up my volumes. After a few moments (make it five minutes) I got black screens again and white pixels after the image came back. Then it didn’t came back. I rebooted by pulling the power cable. I got a brief glimpse of Kodi with severe white noise patterns. Then it disappeared and never came back. Now I can’t get any picture no matter what I try.

This is what I tried so far:

  • Three different HDMI cables. The one that worked on the Vero 4K/4K+. The one that was in the box. Another one that definitely works with all other devices (UHD player, Xbox One, PS4). Makes no difference.

  • Turning on TV first, turning on receiver first, turning on Vero 4K+ first. No difference.

  • sudo apt-get update && sudo apt-get dist-upgrade && reboot - No difference with latest version

  • Changing modes with echo 42210bitnow | sudo tee /sys/class/amhdmitx/amhdmitx0/attr (also tried 2160p60hz and 8bitnow). No picture.

I can SSH into the device. This is the video output config shown

osmc@osmc:~$ cat /sys/class/amhdmitx/amhdmitx0/config
cur_VIC: 4
VIC: 4 1280x720p60hz
Colour depth: 8-bit
Colourspace: YUV444
Colour range: limited
YCC colour range: limited
PLL clock: 0xc000027b, Vid clock div 0x000a339c
audio config: on
3D config: off

When I connect the device directly to the TV (LG E6) to a port which has Deep Color disabled instead of the receiver I had a bit more luck as you can see:

“Had” because I can’t reproduce that now. The output of /sys/class/amhdmitx/amhdmitx0/config stays the same btw except

Colourspace: RGB

Any ideas what’s left to try?

That looks odd.

Could you try connecting Vero directly to your TV first? Edit: I see you’ve tried that.
Can you make sure the HDMI cable is pushed in fully? A moderate amount of pressure won’t hurt.

dmesg | paste-log would also be handy.


This is the log

Even with a bit of force the HDMI cable(s) can’t be pushed in any further. This is how it looks like

I can’t really remember if it looked like that on my former devices. I also tried all the Deep Color HDMI ports now, no difference, no matter if I had the TV turned on first or not.

The device was packaged very well btw and definitely not damaged. And as I said, this is absolutely the same setup I connected it to that was working fine before. Btw, those network issues are fixed at least looking at iperf3 results…

HDMI connection looks ok. It is not supposed to be pushed any further in.

But did you try connecting the Vero directly to the TV? Alternatively try another HDMI port on your receiver. NB! you can damage the HDMI board in your receiver if you switch port when it is turned on. I have heard of HDMI boards in receivers being killed by disconnecting and connecting HDMI devices while leaving the receiver on. Some HDMI boards still works (get power) when the receiver is in stand-by.

This is what I tried:

Vero 4K+ to Denon X1200 receiver - AUX port and one of the back ports
Vero 4K+ to LG E6 TV - HDMI 1 (Deep color enabled) and HDMI 3 (Deep color disabled)

Three cables were tested, it all makes no real difference, I lose the picture all the time.

However, I let the unit cool down and tried again. Suddenly I get the normal picture again. It fails after a few minutes, goes black and doesn’t come back. Another cool down, another 2-3 minutes of screen.

Once the screen goes black there’s no way to bring it back. Other devices work fine on the HDMI ports (just tried the new Fire TV 4K stick).

Edit: It’s not the temperature, I just monitored /sys/class/thermal/thermal_zone0/temp and it goes black at just 42 degrees.

Of course, the device could be faulty.

It seems like a case of very bad luck. To rule out any problems with my setup I directly connected the Vero 4K+ to my reliable Sony KDL-40W4000 I still have in another room. Plain old 1080p with a picture still very nice to look at after nine years. TV is turned on first, Vero 4K+ after.

The HDMI cable from the Vero just gives a “Signal not supported”.

The other cable I have does this:

After that it’s blank.

I suspect a bad solder joint on the HDMI PHY.
Please send me a PM. I’ll have a replacement sent on an express service to you first thing Monday morning.

We will worry about getting the faulty unit back later.

I’m very sorry you’ve experienced the problems you have. I’d like to make this up to you.



1 Like

Thanks Sam, as usual your support is second to none! Sending you a PM now.

I just have to say; this is fantastic service - you never get this anywhere else these days (Trinnov is close, but not quiet there).

It looks like this was indeed a hardware issue and a replacement has now resolved things.