No picture at all Vero 4k kodi 19.1

Last night i was adding my library in my vero4k with the newest firmware with kodi 19,1. This morning when i went to see if everything was added, I got no picture at all. the toothpick method, new hdmi cable, dident do the work, And icant reinstall becuse off no picture is showing up. Any clues? Im thinking of the powersupply, Can i use a powersupply from an older Vero to try if it works?

Older as in older Vero4k then yes. Older as that then no.
Just compare the specs, should be 5V/2A.

Does the Vero show up on the network?

Hm then my idea about switching the powersupply is out. No its not turning up in the ntework.

So your old one was a Vero2? I am not sure but I think that was a different PSU but check the specs.
Alternatively for testing you can power the Vero via a USB A-A cable.

The one before this vero 4k vas a vero 4. But when im reading on the vero 4 its 5V/2A on that one to. Iwas looking at the wrong numbers. i will try it.

Actually currently is Vero4k+ the Previous was Vero4k.

That is correct, actually I corrected my post above as I by mistake wrote 2.5A

tried the othere psu now, Same problem occurs

That’s not a good sign. Can you show the content of the USB Stick you are trying for reinstall?

its just the 2021.08-1 imgage for the Vero 4K / 4K + using the program osmc-installer on the pc to prep the usb. And it contains the kernel file and filesystem.tar file and a dtb file

Should be fine. You could try a SD Card instead of a USB Stick.
Otherwise maybe @sam_nazarko has an idea.

yea @sam_nazarko do you have any ideas on what the problem can be?

From the information so far – not yet,


Did some tests today and now its completly dead. its not even lightning up tried 2 differnt psu and 2 other hdmi cables.
No warranty left. So i will order a new one in a cuple of weeks.

Contact and we will see what we can do for you.

No warranty doesn’t mean we can’t try and fix it for you.

I have sent you a mail :smiley: