No Posters and Artworks after using OSMC Skin Scraper

Thanks mate. I only mentioned OSMC Skin since it was the one that was STILL scraping when I switched back to AEON MQ7 and scraped again. Perhaps that corrupted my database.
I don’t think it’s an issue with TheMovieDB since I can confirm that the artworks were indeed scraped and downloaded properly.
I tried manual searching for each movies as well (popular ones like the latest Star Wars) but posters and artworks still won’t show even if properly downloaded and scraped by Artwork Beef and Universal Movie Scraper :frowning:

Are you using a program that is generating nfo files outside of Kodi?

Hi Darwin.
No, I’m not using other softwares.
I only use the Universal Movie Scraper from kodi and Artwork Beef for the extra artworks.

You could try texturecache.py to clean up the DB and see if that helps.

Does the artwork show if you manually download it and add it?

@bmillham
I tried to use offline method from Artwork Beef and the artworks appeared meaning they are already saved on my database.
Can you point me where texturecache.py is? Do I need to delete it?

Have a look at this: Clear all the image cache then reload it

I just setup a folder with a dummy file for the new star wars movie and set it to scrape with the Universal Movie Scraper. The movie got added but the artwork did not. I then brought up the information window for the movie and hit refresh and it was able to get the full information. I think there is probably an issue with the scraper. I doubt you have a database, or cache problem.

1 Like

Whoa! All this time I was thinking I have a corrupt database!
So it’s confirmed that it’s an Issue with the Scraper?

I didn’t say that. I said I tried one file and it didn’t scrape correctly, but issues with scrapers are very common, and what you describe sounds like a scraper problem. This being due to database corruption is not something I ever remember seeing (so likely not common). Take a breath and try again tomorrow. If the problem persists I would then check for an update to your scraper and/or check the appropriate thread for that scraper on the Kodi forum. If you want to know for sure you could always do a change content on your source and try TheMovieDB instead.

1 Like

TMDB just did a major overhaul.
Movies that I already had scraped iwth posters and fanart refreshed and lost fanart.
I went to their site and sure enough, plenty of artwork was lost when they did their upgrade.
So I have been adding stuff but not sure how long it takes before the new artwork will be scrapable.

Example: Next Friday (2000) - Backdrops — The Movie Database (TMDb)

I just added that “backdrop”.
Previously their database had stuff here but for some reason it’s now empty.

This one lost it’s poster and it’s artwork so I had to add both: How to Be a Man (2013) — The Movie Database (TMDb)

And here’s another fanart I had to upload for them: Mr. Mom (1983) - Backdrops — The Movie Database (TMDb)

Anyway, I think it’s on TMDB’s side and I’m not sure there will be a fix either.
The community will just have to rebuild the database I’m guessing.

Get a load of this…
Some of the files are still on their server but not accessible through Kodi or even the website.
Look at this search result: site:themoviedb.org "the bible in the begining" at DuckDuckGo
That’s a movie I had in my library that lost it’s cover when I refreshed.
The cover is still there if you search for it through duckduckgo.com and you can even see it being hosted by their server at : https://image.tmdb.org/t/p/original/ujb4KbiCKFYH0PGvqLhMvBeKWqX.jpg
But if you go to their webpage they don’t even show that poster as an option: The Bible: In the Beginning... (1966) - Posters — The Movie Database (TMDb)

EDIT: I’m going to download it and then reupload it so it may show up eventually. So far none of my uploads have been showing up unless the movie didn’t have anything at all, but if it has atleast one image it just takes my upload and says thank you but never displays it.

all links work for me … must have been a temporary issue at tmdb.org :man_shrugging:

So you can see this poster:

On this webpage:

???

Yeah, all the links I posted work, but you can’t get that poster by navigating their webpage or from Kodi.

Now I got your point, thx for this clarification. Indeed, on tmdb your preferred poster is listed in the poster overview for this video

but you cannot get it at “View all posters” in English (or German) nor it’s provided via the kodi scraper with language set for the tmdb provider in kodi’s video content menu for the specific folder

But I could login as standard user in tmdb and correct this setting to the right language

Don’t know whether and when this is available for the kodi scraper from now.

tmdb has a support page at https://www.themoviedb.org/talk and since you seem to have uploaded the poster yourself, you should be able to contact them as well.

Meanwhile I can choose your poster also in Kodi (preferred language set to English for this folder in the specific content+tmdb settings menu)

So, there is some delay between time of the correction on the tmdb web page and what can be seen from within kodi.

Wow!
How did I miss that?
Okay, so I’ll make sure my uploads are set to English (not sure why it doesn’t do that by default for me).
So I guess allot of stuff originaly uploaded didn’t have a proper language tag or lost in when they changed their website.
Now I can atleast help rebuild what’s been lost.
Thanks for pointing that out.

1 Like

So I went and made sure all my uploads were set to English and it’s been a few days now and I still cant get them via OSMC.
Anything I can do on the OSMC/Kodi side of things to get it to see the same posters and backdrops I can see in my web browser?

Like I still can’t see that predominately white cover of The Bible: In the Begining in my OSMC.

Mmmhh, what happens if you drop the item from the lib and rescan? That is what I did in my tests.

If you are using UMS, you may need to wait for the update to be pushed: Universal Movie Scraper

1 Like

@Kontrarian Besides waiting for a new scraper I tried uploading a German cover on tmdb (tmdb addon is configured to prefer German language) for “The Bible 1966”, waited some time, refreshed the info … and after that the new cover is available for me:

So, here it works as expected.