No progress bar after update


I have Vero 4K.
When I ran the security update for April the progress bar didnt show when I updated.
This also happened when I ran the May update.
Is this something new?


Not quite sure what you mean.
Can you take a photo next time this happens?


Hi Sam,

I think I may have seen the same thing:

When prompted to exit by myosmc, on clicking yesthe screen just goes blank/black; you do not get the blue screen and so you do not see the progress bar.

I just changed source and back again, and the blue progress screen was showing.

I’d have flagged it before, but with the other issues reported on the day of the update; it didn’t seem a priority.

Thanks Tom.

Okay, I’ll add it to the list and we’ll check it out. This is most likely an issue in the watchdog so I’ll check for changes there.

I’m guessing that Kodi did eventually come back after updating?



Yes everything was fine, as far as I can tell the update was running; just the output hadn’t synced to my TV.

When I switched the source back to vero4k, the update was on about 70% and then rebooted successfully back to the osmc home screen.

Thanks Tom.

How do you know the update was on 70% if you didn’t see anything?
Are you saying you only saw a black screen, or that the progress bar was there, but not filling up.

I ask because I think I may have a different idea of what you saw.


I think he means that the image was blank when exiting to update, but if you change the inputs on the tv and switch it back to osmc it displays the update screen correctly.

That’s weird.

I’ll see if I can reproduce this.


Hasnt happened to me ever either although i’m using rpi3.

Unless its specific to vero 4k.

My problem was that I hit yes on update, Kodi exits, then the screen goes black.
After it’s finished, the Vero 4K reboots into Kodi.

Before the security update last month, the progress bar showed when Kodi exits, now it doesnt.

The_bo is correct, that is what I’m describing.

I’ve never seen this on my pi3s, only seen this behavior on the vero4k.

Ok – will look into it and get it fixed.



Is this problem resolved now?


@sam_nazarko I can confirm this fixed, last time I updated I got the update screen and the progress bar.

1 Like