No PVR add-on enabled

Hi, I can’t get my DVB usb key working, I always get this message, I googled it and found that I have to activate IPTV simple client and activate stalker before reactivating TV, but I still get the same boring message.
Please help !

If you want to use the usb stick, you need tvheadend.
Install it from the osmc store and set up your channels with the web interface. Then use the tvheadend pvr client to view them.

Then I did a fresh install of osmc, then installed tvheadend from the app store, activated the tvheadend client and activated TV, and … got the same message !

Is the USB stick recognized?
Did you configured the tvheadend server?

Provide logs via grab-logs -A

Don’t know…
ok the logs are here :

I forgot to say I activated epg in tvheadend and I don"t have the message anymore but, it still doesn’t work, can’t search for channel, and have tvheadend client disconnection message every 10 seconds…

You don’t know if the stick is recognised or if you have configured the tvheadend server.
In the logs there is no clear trace of the stick. Can you:

  1. Tell us exactly which DVB USB Key you have
  2. Ensure that you have sufficnet power supply to power the external USB devices
  3. Install usbutils sudo apt-get install usbutils and provide the output of lsusb | paste-log

have you entered username/password?

I reinstalled everything again because the key was not detected, now it is…
output of lusb:

No I didn’t entered username/password, where should I put them ?

I put osmc as username and password in tvheadend client, it solved the disconnection, but nothing happens.
If I go to TV and try search for channels, it says none of the connected PVR backends supports scanning for channels.

Is there a way to test channel scanning through ssh ?

Sounds like you have not configured tvheadend server it self. Read up on how to configure dvb stick on tvheadend server. There is a good how to with pictures here in the forum

I have another problem that I already had before the fresh install of osmc, the dvb key is no more recognized as a usb device, or not loaded, I added a power supply to my usb hub but it’s the same.
grab-logs -A :
lusb :

Just to throw in another aproach for the unrecognized stick: initially I had a similar problem with a DVB-S stick. It was plugged in with the drivers installed, still the stick was not visible with lsusb. Turned out Linux can be really picky regarding the order of steps to install new hardware.

You may try unplugging the stick (and rebooting just to be sure). Then installing the driver and only afterwards plug in the stick. This solved the issue to me.

When the stick is recognized, you have to configure tvheadend to use it correctly. Open a browser on any other PC and connect to http://‘IP-of-the-RPi’:9981 which pops up the tvheadend webinterface. If you google the web you’ll find plenty of tutorials, so I will not cover this in detail now. When it’s set up you can scan for channels in the webinterface. You can’t do that over ssh.

I plug the dvb and the wifi keys to the rpi without using the hub and the key is detected.
Then I deactivated tvheadend server, and installed w-scan and did a scan to be sure my key works on the rpi. And all channels were found, also I will retry tomorrow, first to find a tutorial as I haven’t found, and then to map channels in tvheadend. I’ll tell you, thanks.

If you already installed tvheadend from the appstore and your stick is recognized, start at “Setting up Tvheadend”.

Thank you very much for the tutorial however I’m blocked at point 6.3 “Networks”, no pre defined muxes appear in the drop down list.
There are files in /usr/share/tvheadend/data/dvb-scan/dvb-t I don’t know the problem…

I solved my issue by reintalling tvheadend server through the app store.
Thanks for your help.