No remote control after lastest update


#1

Hi, just updated my OSMC the the latest version as it offered the update and when it restarted I noticed I can’t use my remote control anymore which I even used to acknowledge the update. Keyboard with mouse function still works ok though. Any idea what happened and how to bring back the rc?


#2

What remote are you using?


#3

some MCE compatible irDa remote control that has worked fine for years, just stopped after the upgrade.


#4

I don’t know much about this remote. Check Kodi debug log to see if presses are being registered


#5

as far as I can see from the log nothing is being registered. Plugged the same IrDa receiver into a another Raspi which runs on Raspian + Kodi and there it works. Looks like something is missing/wrong after the update.


#6

Nothing has changed re. remotes in this update.
Without a log I’m not sure there’s much to go on unfortunately.

We haven’t had reports of remotes no longer working after this update.


#7

Hi.
My remote not working after update too.

osmc@osmc:~$ lsusb
Bus 001 Device 005: ID 0471:206c Philips (or NXP) MCE IR Receiver - Spinel plusf0r ASUS

logs:
2018.08-1
https://paste.osmc.tv/gelemubira
2018.10-1
https://paste.osmc.tv/agurixicuq


#8

https://osmc.tv/wiki/general/how-to-submit-a-useful-support-request/


#9

I have the same problem.

My wife keeps asking why the remote does not work anymore.
It’s and older USB connected iR remote. it’s been working the last 7 years, with different versions of kodi.

logs : https://paste.osmc.tv/ogefunebum


#10

logs: http://paste.osmc.io/popufegajo.xml


#11

Same issue. Original xbox dongle with Logitech 650. Worked before this evenings update. Not after.


#12

Have you checked in GUI->MyOSMC->Remotes what remote is configured there?
The related configuration file is /etc/lirc/lircd.conf … but this file can be overwritten by updates.
Better concept for changes to this file is to copy the modified lircd.conf to a safe place like /home/osmc/.kodi/userdata, so you can find it again by browsein the MyOSMC->Remotes menu.


#13

I have never looked in this menu before, ny remote have always just worked out of the Box.
What was interresting, is that at én I looked in this menu yesterday, osmc remote was selected as the default remote. I have been through all the remote configurations and none of the works.


#14

correct, my remote control has always worked without any need of adjustments and I never used the rc setup. Nevertheless, I tried all remotes and nothing seems to work. Is there any way of reverting back to the previous OSMC version?


#15

Yes – you can reinstall from osmc.tv/download.

In the interim, I’ll investigate this.


#16

Same problem here too… After latest update TV remote wont work…(it did up until I accepted the update). Tried a clean install but no luck… Any suggestions?


#17

@Hooligan @tzimis86: Could you provide as well logs from your systems?

Just to give a short update, till now it looks like only Raspberries are affected using IR remote receivers which worked before with the mceusb kernel module.
Until this is fixed, you need to re-install the August 2018 OSMC image.

Both logs sets from August and October 2018 OSMC are most helpful like user @Mixei_x86 provided above.


#18

this the log from the current settings:

https://paste.osmc.tv/aqeyulamuw

If there is an actual rollback that would not necessitate starting again I can do the logs from that, otherwise I will carry on with the current version (hoping for a fix) using my PS3 keyboard/touch pad and my phone app…

Warren


#19

@Hooligan Could you also provide after

sudo apt-get install usbutils 

the outputs of

sudo lsusb
sudo usb-devices

This IR receiver isn’t handled by mceusb (?), so the nature of the issue is more general?


#20

here’s the output of the usbutils with the current non working configuration:

osmc@osmc-wohnzimmer:~$ sudo lsusb
Bus 001 Device 005: ID 0471:2168 Philips (or NXP)
Bus 001 Device 004: ID 046d:c52b Logitech, Inc. Unifying Receiver
Bus 001 Device 003: ID 0424:ec00 Standard Microsystems Corp. SMSC9512/9514 Fast Ethernet Adapter
Bus 001 Device 002: ID 0424:9514 Standard Microsystems Corp. SMC9514 Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
osmc@osmc-wohnzimmer:~$ sudo usb-devices

T: Bus=01 Lev=00 Prnt=00 Port=00 Cnt=00 Dev#= 1 Spd=480 MxCh= 1
D: Ver= 2.00 Cls=09(hub ) Sub=00 Prot=01 MxPS=64 #Cfgs= 1
P: Vendor=1d6b ProdID=0002 Rev=04.14
S: Manufacturer=Linux 4.14.78-2-osmc dwc_otg_hcd
S: Product=DWC OTG Controller
S: SerialNumber=3f980000.usb
C: #Ifs= 1 Cfg#= 1 Atr=e0 MxPwr=0mA
I: If#= 0 Alt= 0 #EPs= 1 Cls=09(hub ) Sub=00 Prot=00 Driver=hub

T: Bus=01 Lev=01 Prnt=01 Port=00 Cnt=01 Dev#= 2 Spd=480 MxCh= 5
D: Ver= 2.00 Cls=09(hub ) Sub=00 Prot=02 MxPS=64 #Cfgs= 1
P: Vendor=0424 ProdID=9514 Rev=02.00
C: #Ifs= 1 Cfg#= 1 Atr=e0 MxPwr=2mA
I: If#= 0 Alt= 1 #EPs= 1 Cls=09(hub ) Sub=00 Prot=02 Driver=hub

T: Bus=01 Lev=02 Prnt=02 Port=00 Cnt=01 Dev#= 3 Spd=480 MxCh= 0
D: Ver= 2.00 Cls=ff(vend.) Sub=00 Prot=01 MxPS=64 #Cfgs= 1
P: Vendor=0424 ProdID=ec00 Rev=02.00
C: #Ifs= 1 Cfg#= 1 Atr=e0 MxPwr=2mA
I: If#= 0 Alt= 0 #EPs= 3 Cls=ff(vend.) Sub=00 Prot=ff Driver=smsc95xx

T: Bus=01 Lev=02 Prnt=02 Port=03 Cnt=02 Dev#= 4 Spd=12 MxCh= 0
D: Ver= 2.00 Cls=00(>ifc ) Sub=00 Prot=00 MxPS= 8 #Cfgs= 1
P: Vendor=046d ProdID=c52b Rev=12.01
S: Manufacturer=Logitech
S: Product=USB Receiver
C: #Ifs= 3 Cfg#= 1 Atr=a0 MxPwr=98mA
I: If#= 0 Alt= 0 #EPs= 1 Cls=03(HID ) Sub=01 Prot=01 Driver=usbhid
I: If#= 1 Alt= 0 #EPs= 1 Cls=03(HID ) Sub=01 Prot=02 Driver=usbhid
I: If#= 2 Alt= 0 #EPs= 1 Cls=03(HID ) Sub=00 Prot=00 Driver=usbhid

T: Bus=01 Lev=02 Prnt=02 Port=04 Cnt=03 Dev#= 5 Spd=1.5 MxCh= 0
D: Ver= 1.10 Cls=00(>ifc ) Sub=00 Prot=00 MxPS= 8 #Cfgs= 1
P: Vendor=0471 ProdID=2168 Rev=01.04
S: Manufacturer=PHILIPS
S: Product=OVU710023
C: #Ifs= 1 Cfg#= 1 Atr=a0 MxPwr=100mA
I: If#= 0 Alt= 0 #EPs= 1 Cls=03(HID ) Sub=01 Prot=01 Driver=usbhid