No response from support even though promised a week ago. Faulty 4K+

Worked out of the box when I received it in December. Ran the automatic updater to get the latest version and it hasn’t worked since. Getting visual glitches when booting up. Sometimes getting the setup menu, but it’s unresponsive. Can hear UI sounds, but nothing is happening. Got it to boot once, but the menus hang, flicker and eventually freeze up.

Was sent a new power supply, still same problem. I understand this is most likely power related, but everything else in my house is working. I’ve tried the Vero with different HDMI cables, different inputs, different TVs, different wall outlets, with network attached, without network attached, with remote, without remote, with a different remote etc. Reinstalled everything with a thumbdrive, tried different versions going back to june 2020. Sometimes SSH work and I’ve ran the updater there, still the same problems persist.

I’ve found others on the forum here with the exact same problems, sent out a new power supply, not working, but they finally get it powered through USB. I’m not going out of my way to get a male to male USB-A cable to find out if that fixes things… this is a new product. From searching through the forums it looks liket he power supply has been a problem a long time… sending out interference to other devices and so on… sounds like a fire hazard?

I was promised a response from support a week ago, but not hearing back. I can see activity on the forum, and am getting annoyed.

If this is “unfixable”, just send out a return slip or cover postage and I will ship everything back and get a Kodi-box that actually works.

Videos of glitches:

This doesn’t sound right. Can you please let me know the ticket number so I can check this?

#888167 - sorry, first one was the second mail I sent as I didn’t get a response.

Thanks. I’ll check this in a couple of hours when at my desk



I had a look at this and we did send a response. I have re-sent it just in case it was not received.

As explained previously, every device is tested before dispatch and goes through a number of tests, but we are only able to test a small number of power supplies from each batch for practicality reasons. Therefore, we shipped you a new power supply as a cost effective and potential solution.

As this hasn’t resolved the issue, you can either return the item for a full refund or we can replace the device with a new, functioning device.

You can respond to the ticket with what you would like to do. I hope we can restore confidence in our products in the near future for you



Just replied. I didn’t receive a reply from you on any of the tickets untill today. The last I received was last Wednesday with you saying you would follow up the next day. I checked both online osmc, junk mail etc. Either way, it doesn’t matter as long as I get it solved one way or the other.

Odd – if you aren’t getting any replies, let me know. As an aside, replying to the email will always re-open the ticket and bump the priority, so will get you the quickest response