No S/PDIF sound 2016.09.1

Hi, S/PDIF output works just fine with OSMC_TGT_vero1_20150628.img. Since then all new updates I don’t have sound at all. When I go to the Settings - Systems - Audio output and check Audio output device as imx-spdif, S/PDIF and connected via ssh I’m getting this error message trying this command

osmc@osmc:~$ aplay -Ddefault:imxspdif /usr/share/sounds/alsa/Front_Right.wav
aplay: main:722: audio open error: Device or resource busy


Do you know which version worked before? Kodi nor kernel were updated in this update (only an initramfs message), so I wouldn’t expect to see a regression here.

20160628 is a very, very old image.

Can you take a photo of your audio settings and upload a debug log?



This was the last image which is still working fine with my S/PDIF. There are screenshots and log files

grab-log -a

grab-log -X


@sam_nazarko did you check my logs and screenshots?

@sam_nazarko any updates ?


I saw the logs and couldn’t discern anything wrong.

I’m going to try a fresh OSMC install tomorrow, and see if I have issues with playing via SPDIF. I’ll let you know how I get on

@sam_nazarko any updates?

I did not have any problems with SPDIF playback here.

I tested with the latest image. I understand recent images caused problems for you. What was the last one you tried that didn’t work? This would be a better way for me to approach it.

2016.09 works here. Have you tried this?

@sam_nazarko osmc@osmc:~$ cat /etc/os-release
PRETTY_NAME=“Open Source Media Center”
VERSION=“September 2016”

osmc@osmc:~$ uname -a
Linux osmc 4.4.0-6-osmc #1 SMP Sun Oct 2 16:01:23 UTC 2016 armv7l GNU/Linux

@sam_nazarko just to be on the same page. Did you try it on Vero 1s generation ?

Yes, I’m talking about a Vero 1st gen here.

I’ll double check with tomorrow’s update as well


@sam_nazarko Ive just updated to October release, the issue is still there


Can you run uname -a? I wonder if your kernel is held back or another package is. Here’s what I did today:

  • Installed OSMC September update fresh
  • Installed October update (via staging repository)
  • I quickly selected the SPDIF output and my AVR received a signal when I played a quick clip.


uname -osmc@osmc:~$ uname -a
Linux osmc 4.4.0-8-osmc #1 SMP Fri Oct 28 02:56:07 UTC 2016 armv7l GNU/Linux

That seems up to date. Are you able to make a backup and try a fresh installation?

I will check again to see if there is any obvious reason for this not working as expected.


@sam_nazarko I just noticed it’s not 2016 it’s 2015 image, the last working image for me is June, 2015. Since then I don’t have SPDIF sound.

I’ve tried the the fresh installation of October, 2016. Still no sound

@sam_nazarko I don’t have any options left but to keep bothering you … soryy man i know you are busy with product but i need some help


I did check, but didn’t find anything obvious. It’s working here. I understand that isn’t what you want to hear.

There are a fair few SPDIF users of this platform.

Does the port illuminate correctly when playing audio?


@sam_nazarko can i send you device so you can diagnose the issue ?