No settings menu on titan bingie mod, can't revert skin

I got my vero 4k+ yesterday, tried putting the titan skin on it, but after i did i could no longer access the settings, I’m stuck with the skin and can’t do anything to remove it

Is there any way to manually reset the vero 4k+?

I’d provide logs, but I can’t enable or get access to them

You could just change the skin via command line (see access below)
(stopping and starting mediacenter commands only needed if doing this via ssh)

systemctl stop mediacenter
nano .kodi/userdata/guisettings.xml
and change the skin line to
<setting id="" default="true">skin.osmc</setting>
then press ctrl+x, then y, then enter to save and exit nano
systemctl start mediacenter

Details regarding how to access the command line interface can be found here on our Wiki: Accessing the command line - General - OSMC

I tried pressing escape during boot but it didnt get me into the CLI
And I didnt enable SSH in setup unfortunately, so I don’t think it will work, I am not able to test this out at the moment either way unfortunately

Is there any way to factory reset it on the box itself? Or anything else I could do?

Try to press CTRL repeatedly after you plugged in power for a while that might get you the Console.
Otherwise you would need to do a full reinstall.