No share with samba

From one day to another, I could’nt acces some of the shared discs. Some worked as usual, but not all of them. I did a factory reset, but now I can’t even se what’s shared with samba. Nothing turns up. I tried to unshare and then reshare the discs in win7, but they still don’t show up.
I have no idea at all what to do, but I suppose it’s something simple I just don’t see.
Can anyone please point me in the right direction?


Can you explain from where to where you try to share?

All the discs I want to acces from my Vero are put in a win7-computer. Both computer and Vero are connected to a router,

And how are you trying to access them? Via the Kodi Menu or have you used Kernel Mounts (e.g. autofs)?

I have always used samba, and it has been sufficient enoug. Samba it is. After a lot of trying, I saw that samba was using the latest version, so I changed it to no 1. Suddenly I could see WORKGROUP again, wich made me very happy. Sadly, only half of my discs could be connected to. The other half required usernam and password. The username osmc was already there, but It still wont work, regardless of password osmc or none att all.
I really can’t understand why some of the discs are accesible, and some not. They have all been shared in the same way.


Samba is the right way it’s just a question if you use the internal Kodi implementation or external solutions like fstab/autofs.
But from what you write you are using Kodi internal solutions.

Where did you changed that? On Windows or on Kodi?

That would be the username/password of your Win7, did you have osmc as a user?

I changed that on Kodi, I don’t know where to do it on Windows.
As far as I know, I don’t have any passwords at all for my Win7, do you mean it’s the username I have when I log in to the computer? I’ve tried that as well, without success.


Yes, it can be the one you login with but you also can create additional users. You just need to ensure that the user you use has access permission on the share. Guest Shares are not working.

have you tried adding the samba user osmc from a terminal window as you have changed samba version it may no longer know the account try this

smbpasswd -a osmc

in a terminal window (ssh)

Also need to see if osmc is a valid user in the smb.conf… I assuming it is as you state it show it to you by default.

if that doesn’t work go here and follow the directions and add your windows user account to your samba box
([How to add or delete a samba user under Linux – The Geek Diary]

This topic is about accessing shares on a Win7 machine, So nothing to do with the samba user on OSMC

My Bad… I just had a headache awhile back with the new version of samba in the other direction… Sorry

Can you edit your SMB.conf file… I had a problem with the new version of samba not wanting to see any windows shares… adding this helped seeing them

wins support = true
client max protocol = SMB3

Seems they default SMB4 now for security reasons

Do NET View on your windows PC and see what it shows as shares…


The poster was using Kodi to access the SMB shares, for that the change of min/max SMB protocol is done within Kodi as the poster described that he changed it to SMB 1 in his 3rd post.

As of the year 2022 there is no SMB4, highest samba protocol setting is SMB3 with the default one then using SMB3_11 which stands for Windows 10 SMB3 version.

Sorry meant samba version 4 not the protocol. I just know what worked for me…

Win7 supports samba vers=2.1, nothing later.
I don’t use a Vero and I don’t use samba from other players, but I do have an Ubuntu client that connects to a win7 share using autofs.
The main options are:


Those can be used in an fstab line, with any other required fields (there are 6 fields, that line above is 1 of the fields). The line must be on 1 line. Not 2.
Be certain to correctly create the credentials file with the username= and password= lines. A domain= line may be required. They are not on my system, however. The username/password are for WINDOWS. The credentials file can be named anything. It is more secure to place it somewhere that only root can access and to prevent all other users from having any access to it.

Nearly all settings in the /etc/samba/smb.conf file are for a samba server only and have ZERO impact on client connections. But there are a few settings that are specifically for the client. Also, some versions of samba require a full reboot for changes to be seen, which is really odd on Linux. Most of the time, sending a -HUP signal to a running process will force a re-read of any config files … or using a systemctl restart command for the service. But that doesn’t work for some samba stuff - I don’t know which.

The client min protocol should be set follow this from the manpage:

·   SMB2: Re-implementation of the SMB protocol. Used by 
    Windows Vista and later versions of Windows. SMB2 has 
    sub protocols available.
           ·   SMB2_02: The earliest SMB2 version.
           ·   SMB2_10: **Windows 7 SMB2 version**.
           ·   SMB2_22: Early Windows 8 SMB2 version.
           ·   SMB2_24: Windows 8 beta SMB2 version.
    By default SMB2 selects the SMB2_10 variant.

Enabling WINS on a network without a WINS server (which is usually enterprises, not home LANs), isn’t useful.