No signal on Dell monitor after updating OSMC

I have a Vero 4K+ attached to a Dell 2407WFP monitor (with an HDMI to DVI passive adapter) and it was working well for a long time on Kodi v17.

When upgrading OSMC (to Kodi v18) about a year ago, it resulted in a black screen/no signal on the monitor. This appears to occur at the very beginning of the boot process, as the monitor does not come out of standby mode. There were no such issues on Kodi v17.

I stopped using it since then, but I’d like to start using it now so I tried updating it to Kodi v19 (OSMC 2021.08-1) but unfortunately it still behaves the same as v18.

Logs as follows:

Please try the following command lines

systemctl stop mediacenter
nano ~/.kodi/userdata/guisettings.xml

Change this line
<setting id="videoscreen.screenmode">0192001080060.00000pstd</setting>
<setting id="videoscreen.screenmode">0192001200060.00000pstd</setting>
Save the file and
systemctl start mediacenter

If it doesn’t work, post logs again.

1 Like

Hi, thanks for the quick reply. I have performed the above steps over SSH and it hasn’t resolved the issue. Then I rebooted, and still nothing, so here is the new set of logs:

Just to clarify: you don’t see ‘Please Stand By’ or the OSMC splash screen when booting?


Correct, nothing on the screen as the monitor remains in standby mode.

With Kodi v17 before, the monitor would wake from standby early in the boot process where I did see those things before it launched Kodi.

According to your logs, we are sending the correct resolution at the correct frequencies. Even if we weren’t I guess you should have seen an ‘out of range’ message. It’s as if the signal isn’t strong enough - have you got another cable/adapter you can try? And are you happy that cable/adapter works with another HDMI source?

I don’t have another adapter but I’ve swapped over the HDMI cable and it doesn’t help. The cable/adapter works fine with my Pi 4, NUC, and PC, and indeed this very Vero when its on an older version of OSMC with Kodi v17.

Would it help if I downgrade OSMC to a working version and grab logs from that?

Thanks for the offer. TBH I doubt this is about kodi version - more likely kernel version but the kernel for v17 was the same (major) version for v18 Kodi. If you can pinpoint the (preferably the latest) version of OSMC that works then we could have a look at the differences. But a lot has happened since Krypton …

If you do have time to downgrade and grab logs, that would be good.

Edit: I found this which suggests you may indeed have an issue with HDMI signal strength. However

  • we do have another user with a 2408WFP and he’s getting a picture, and
  • yours is a 2407WFP so no HDMI input.

I’m trying to find out if there’s something like config_hdmi_boost for Vero. My guess is the signal is getting reduced by the HDMI-DVI adapter.

1 Like

Hi thanks again for looking into this. I have had some time to install various versions of OSMC to pinpoint where the issue started. Each installation is a clean reinstall from an image file with a USB drive.

OSMC_TGT_vero3_20180805 = OK
OSMC_TGT_vero3_20181215 = OK
OSMC_TGT_vero3_20190105 = OK
OSMC_TGT_vero3_20190424 = OK (first update to Leia)
OSMC_TGT_vero3_20190808 = OK (2019.07-1 Leia 18.3)
OSMC_TGT_vero3_20191118 = OK (2019.11-1 Leia 18.5)
OSMC_TGT_vero3_20200204 = OK (2020-01-1 Leia 18.5)
OSMC_TGT_vero3_20200607 = OK (2020-06-1 Leia 18.7)
OSMC_TGT_vero3_20201023 = OK (2020-10-1 Leia 18.8 with Debian Buster)
Logs at this point

The next update (OSMC_TGT_vero3_20201227 - 2020.11-1 - Leia 18.9) and indeed any previously working USB update listed above (after flashing a new image to the drive each time), fails to show the installation screen on boot and the monitor remains in standby mode. But without a USB drive present, it boots OK into 2020-10-1 Leia 18.8 with a working video output.

So then I updated OSMC online via the GUI (to the latest version 2021.11-2) and after rebooting, the monitor fails to come out of standby. Here are the logs after the update.

Given the the numerous number of “OK” successful installations above with my HDMI cable and adapter, these appear to be working correctly, so perhaps something changed in the Debian Buster release that reduced the HDMI signal strength?

Good work, thanks. Try this:

Stop mediacenter and edit guisettings.xml to change:
<setting id="videoscreen.screenmode" default="true">DESKTOP</setting>
<setting id="videoscreen.screenmode" default="true">0072000480060.00000pstd</setting>

You may also need to do:

sudo fw_setenv hdmimode 720x480p60hz

In the Leia logs, that mode seems to work. If that’s good, you can try other modes from the Kodi settings menu. I’ve still no idea why we can’t get the native 1920x1200 to work.

1 Like