No signal on HDMI from OSMC

Hello guys.

I am new to RASPBERRY having the last model pi3. I have one issue with OSMC. Here are the details:

Installed the raspbian - Jessie on SD Card (8gb) plus the OSMC. Both were successfully installed. I can go to the raspberry GUI without problem. The OSMC is the problem. When I firstly rebooted from the Raspbian and went to the OSMC it worked fine however I was not able to find any add ons, even when I had network connection. I am having my PI3 connected to the TV on HDMI cable. When I rebooted the OSMC for changes to take effect the TV showed me “no HDMI signal” from the Raspberry. But the ssh to CLI is working fine, and can log in with the default osmc credential. I am very less experienced with LINUX, just getting to it. I have reinstalled both on the SD Card once again, but the same issue appears again.
Note: my TV is Samsung Smart TV. But I guess the TV is not the issue, since the Raspbian GUI is working fine.

Can somebody recommend something how to solve this issue? Many thanks

What have you “changed” before the reboot to happen?
Provide logs with ssh into OSMC and grab-logs -A


Nothing special, I just found my remote control so I was able to operate the OSMC menu with TV remote control.

here are the logs: actually nothing

root@osmc:/home/osmc# grab-logs -A
grep: /var/log/apt/term.log: No such file or directory
grep: /var/log/apt/history.log: No such file or directory
Logs successfully uploaded.
Logs available at

I did have turned on only the raspbian not osmc, so I believe the logs are gone. Are`nt they?

21:38:10 10.177663 T:1958212144 NOTICE: Found (640x480@60.000000) at 16, setting to RES_DESKTOP at 16

Your Pi is booting at 640x480 at 60Hz. This is probably due to it either not detecting any HDMI connection at all, (thus booting with the composite video output active) or your monitor is not providing any EDID information, which causes it to default to 640x480 over HDMI.

Please provide the output of:

tvservice -s
tvservice -m CEA
tvservice -m DMT

Also, try completely unplugging the power to your monitor/TV for a minute then reconnecting it, the reboot your Pi. Sometimes some screens stop providing EDID information and require powering off and on.


I have tried all of these what you mentioned. Here is the output:

root@osmc:/home/osmc# tvservice

bash: tvservice: command not found

Also the cable thing did not work.

Don’t run the command as root

I have the same problem.
My components are Pi3 and Samsung TV, too.

I installed only OSMC in my SD Card.
When I start the system for the first time, all thing is fine.
When I restart the Pi3 for the second time, it looks like the Pi3 loses the initial configuration and doesn’t show in TV (HDMI No Signal).

I will run grab-logs - A command:

What’s happen?

Well “same” is always tough to say especially for old threads like this where no progress has been made. Suggest the following three test (one at a time) to get an idea whats wrong:

  1. Power down (unplug power cord) TV and the Pi3 for 2 minutes. Then start the TV and then Pi3
  2. Try a different HDMI cable (any special long cable you currently use?)
  3. To ensure that it is not related to Kodi just having issues try to start with a clean Kodi install mv .kodi kodi_backup

It’s work in to first step!!!
I turn off TV and Pi3 after turn on the components and works!!!

But what happens??

Hard to say exactly but most likely the Pi got wrong EDID information before.

1 Like