"No signal" on Samsung SUHD TV when setting resolution to 3840x2160p


just hooked up the Vero 4K to my Samsung TV (UE49KS8090 SUHD) with the provided HDMI cable. Vero defaults into 1920x1080p resolution. Once I try switching to 3840x2160p, the screen goes black and the TV shows a “No signal” message. 1920x1080i and 1280x720p work, changing refresh rate to 50, 30 or 24 doesn’t help.

What do I do wrong?

I guess your problem is related to this.

Indeed. Make sure you follow that instruction and try another hdmi cable as another resort


Thanks for the advice - I applied the update, didn’t help, then changed the HDMI cable. Now it works! The cable delivered with the Vero 4K seems not to be fully 4K ready … you might want to look into this for further batches.

Tested 4K content (H.264 and H.265), runs smoothly, HDR works and makes a significant difference. Great!

Did you power cycle the TV after installing the update? The bundled cable should work with 4K fine. Either way, I’m glad everything is up and running now.

Yep, I did. It was definitely changing the cable that did the trick … might the Samsung be particularly picky? No worries, I have abundant supply of HDMI cables as I just retired my DVD player etc. etc. :blush:

Possibly. I’ll keep an eye out on this. Thanks for the report and glad everything is worked as expected now.