Please stand by


Today I received my brand new vero4k. When connected to my TV, it doesn’t complete boot: message “Please stand by” is shown. If I connect the vero4k to a computer monitor (Asus VS24AH-P) it boots just fine. My TV is a Vizio M60-C3, a “pre-standard” 4K TV. The vero4k will be stuck at bootup if it is connected to hdmi port 4 ( ULTRA HD VIDEO 4K @ 30 Hz) or 5 (ULTRA HD VIDEO 4K @ 60 Hz). I didn’t try with hdmi ports 1 to 3, since they are identicals to port 4. I tried with the hdmi cable provided with the vero4k and another cable, same issue.

Any hints ?


P.S. Don’t know if the logs persist across reboots. In anycase I uploaded them here:


Do you have a non-4K TV you can test this on temporarily?

Edit: just saw it works on a computer monitor. @bmillham is experiencing the same issue, so looking in to it.



Does the Please Stand By initially display in 1080p, and then switch to 2160p? That’s what mine is doing.

yes same here. large font at first (1080p) then smaller when switched to 2160p

Good to confirm that. @sam_nazarko is working on the problem as we type :wink:

You can boot without the HDMI connected, wait a bit and then connect the HDMI and it will work.
But of course not totally, no CEC and I noticed audio oddities since the TV capabilities are not detected at boot. But at least that will allow you to play with the 4K until the problem is resolved.

Thanks, but on my TV this workaround doesn’t really help. I can see and use the vero4k with the TV, but they will sync in 1080p only, no 4k. Didn’t try cec nor audio at this point, it’s all new to me.

Hi – this is not a suggested workaround, I just wanted to confirm whether or not the device works on a 1080p set


Hello, I received my Vero 4k today and did a manual update on it after I did the initial setup. I got the standard notice about leaving OSMC to install the update, I did that and after the reboot it hung on Please Stand By. I waited about 10 minutes with no change.
I tried reinstalling the Vero 4K image using the mac installer. It went through the setup process, said that OSMC had been installed successfully but on reboot, I’m still at Please Stand By. One other note. While the update was downloading, I tried to install TVHead. I got an error saying that it failed and that I should report this too.

Any help would be appreciated.


I’m sorry to hear your Vero 4K isn’t working as expected.

Can you reinstall with a different SD card if you have one at hand. When your device boots up, can you try and paste a log after trying to install TVHeadend?

Can you also confirm if you’re connected to a 1080p or 4K set?



I’m connected to a 4K set. When it first boots, the Vero is at 1080, after a second or 2 it switches resolution to 4k. I thought I had a bad sd to micro sd adapter so I tried another adapter but with the same micro sd card. No change. I’ll grab another card tomorrow. I used the mac installer for the first, then used win disk imager to install the disk image downloaded from your site on the second try… OSMC_TGT_vero3_20170301 is the image linked to the 4K download option

@sam_nazarko is working on a fix for this. I’ve also have this happening.

I’d like @Jlpeel to confirm that it’s not a problem on a 1080p set first.

Good call. I plugged it into a 1080 computer monitor and it booted fine.

Okay – good stuff.

It’s a known problem and I’m working on it. I’ll let you know when this is resolved, and you’ll be able to update on the 1080p monitor and move over to the 4K one.


Thanks for the quick reply. I appreciate all of your hard work.

I’m merging this thread with another as the issue seems related.


Thanks for your patience. I’ve found an issue that can prevent Vero 4K from booting correctly on 4K TV sets that advertise a 4K resolution as their preferred mode. This should now be resolved in these two commits:

I’ve pushed this as an update – so you should be able to update within an hour. You should be able to connect your Vero 4K to a 1080p display, update, and then things should work fine on your 4K display. You’ll need to reboot between this. As it’s almost 5AM here, and I can’t monitor this closely, I haven’t pushed the update to the main repository yet, only the testing one.

If you are familiar with the command line, you can test these changes quite trivially.

I’d appreciate it if you could test this and provide feedback before we release this as an update to other users. To test this update:

  1. Login via the command line
  2. Edit the file /etc/apt/sources.list
  3. Add the following line: deb jessie-devel main
  4. Run the following commands to update: sudo apt-get update && sudo apt-get dist-upgrade && reboot
  5. Your system should have have received the update.

Please see if the issue is resolved.

I also recommend you edit /etc/apt/sources.list again and remove the line that you added after updating. This will return you to the normal update channel.

Thanks to @bmillham for testing the solution.



I just wanted to add a thank you to @sam_nazarko for the quick fix!

If you don’t have another monitor available, you can still fix this. Just disconnect the HDMI, power cycle the Vero and wait a few seconds. Then re-connect the HDMI. Follow the above instructions to do the update.

Good morning; the fix is working for me as well; many thanks.

Thanks for testing