No signal when connected to TV

Hoping someone can help troubleshoot this…

  • Installed latest image (OSMC_TGT_rbp4_20230831) on a new Pi 4B+
  • Used a 1440x900 monitor to set up OSMC & Kodi
    ** NOTE: had to use first Pi HDMI port; second wouldn’t display beyond splash screen)
  • Moved Pi to new LG 4k tv
  • On boot, get OSMC splash screen, then “no signal”
  • Can SSH in
  • Renamed guisettings.xml, rebooted: same result
  • Logs posted to
    ** grab-logs process reported: “An error occurred while grabbing edid-decode:
    subprocess.CalledProcessError: Command ‘[’/usr/bin/edid-decode’, ‘/sys/class/drm/card1-HDMI-A-1/edid’]’ returned non-zero exit status 255.”

So do I have something in my config that’s preventing Kodi from detecting/switching to a resolution supported by the TV? Where is it getting 1280x720 @ 50?

The 1280x720 is a fallback. It’s not talking to your display it looks like to me. It should be plugged into the HDMI port on the Pi closest to the USB C port. I would try another HDMI cable and see if you have better luck with that. If your using a micro HDMI to HDMI adapter instead of a cable that has the respective plugs on each end I would consider ditching the adapter as they seem to be more prone to problems. The edid-decode message is expected as that section only picks up from the Vero.

I have an unrelated question though. I see that you moved your PVR database to MySQL. I thought I had read that is was unsupported in Kodi. Am I mistaken about this?

And an unrelated comment. Your sources are using credentials and this is really not best practice anymore. The current standard is to just have the source path in sources.xml and a path substitution pair for the credentials in passwords.xml. I’m assuming you have been using this file for quite a while as for I think three versions of Kodi now if you manually input that type of path in the GUI it automatically splits it into those two files. Also the import watched status is no longer needed as those are currently the defaults (I think Kodi switched it in v20).

Great notes, thanks!

The cable has been working with an HTPC connected to the same TV with no problems, so I’m pretty confident in that; but while the micro-HDMI adapter claims to be 4k-compliant, it’s probably the source of the issue.

[Side rant: Moving to micro HDMI was a TERRIBLE decision by the Pi foundation. I understand wanting to fit two HDMI ports, but doing so forces all your users to add adapters or new cables anyways, so a single DisplayPort would have accomplished the same thing. Rant off.]

You’re right that it’s “officially” unsupported, but I’ve been using a central MySQL db since the XBMC days and it’s worked flawlessly. If you have multiple media players sharing a central source, I highly recommend it! Once you’ve set it up on one device, just copy the AdvancedSettings.xml to any others and you’re g2g. Or do what I do, and create a symlink for everything that can be common across all devices (advancedSettings, library, addons, addon_data) pointed to a network share.

Good to know, thanks! Yeah, I have a lot of very old data files that I’ve been using for at least a decade, so there’s probably lots of old cruft I should clean up in there. :slight_smile:

I did a lot of digging and looking around before I updated most of my house with RPi 4’s. I saw that even the supposedly higher quality adapters were hit and miss in end user reviews. That combined with the fact that you are adding a larger lever to a fairly small jack made me form the opinion that they are a bad idea. You might try doing a HDMI voltage boost to see if that will help. I’m not sure if that works from config-user.txt so you might have to add it to config.txt.

I agree.

I know about that with movies and series; been using it since forever as well. I’m just talking about the PVR db. That is what the <tvdatabase> in your advancedsettings is, isn’t it? I think your log is the first time I have ever seen someone use that option.

I think your skip-step entries might be a bit out of date as well but TBH I was feeling a bit too lazy to look it up and check. I think current is to just add in the time that you want added to stock and then select the ones to use in the GUI. I think with what you have now it might be hiding the GUI option and limiting you to the single small step. It is hard to remember as they revamped that years ago now.

I have a new cable coming tomorrow; if that doesn’t fix it, I’ll try the voltage boost.

Oh! Sorry, missed the critical “PVR” bit in your question. IIRC, that is a left-over from when I was experimenting with creating a shared streaming-channel library across all players. Didn’t pan out so I abandoned it, but apparently left that behind. Doesn’t really matter since I don’t use a PVR on any devices.

I think you’re right, as that was actually my intention; I wanted to remove the GUI option and hard-code those skip-steps so I don’t have to set them up in the GUI every time I do a new install/setup. It’s probably no longer the best way to do it, but it works and I’m lazy. :slight_smile:

1 Like

There is nothing wrong with pushing a guisettings.xml setting via advancedsetting.xml. If you look at the beginning of your Kodi log you will see OSMC is doing the exact same thing for a couple settings. I guess I just assumed something different since a fixed +/-10 seconds seems really small and if you play something with chapters they disable the ability to do large skip steps.

We have seen some issues with the numbering of the Cards/Ports.
What does
ls -lah /sys/class/drm/card1-HDMI-A-1/
ls -lah /sys/class/drm/card1-HDMI-A-0/

I didn’t know that, thanks!

For skip steps, I find any skipdelay annoying, so I set it to 0 and just use 1 left/right click = +/- 10 secs, 3 = 30 seconds, 1 up/down click = +/- 10 minutes, 3 = 30 minutes, etc.

ls -lah /sys/class/drm/card1-HDMI-A-1/:

osmc@osmc5:~$ ls -lah /sys/class/drm/card1-HDMI-A-1/
total 0
drwxr-xr-x 3 root root    0 Sep  2 16:01 .
drwxr-xr-x 6 root root    0 Sep  2 16:01 ..
lrwxrwxrwx 1 root root    0 Sep  3 11:05 ddc -> ../../../../soc/fef04500.i2c/i2c                                           -20
lrwxrwxrwx 1 root root    0 Sep  3 11:05 device -> ../../card1
-r--r--r-- 1 root root 4.0K Sep  3 11:05 dpms
-r--r--r-- 1 root root    0 Sep  3 11:05 edid
-r--r--r-- 1 root root 4.0K Sep  3 11:05 enabled
-r--r--r-- 1 root root 4.0K Sep  3 11:05 modes
drwxr-xr-x 2 root root    0 Sep  3 11:05 power
-rw-r--r-- 1 root root 4.0K Sep  3 11:05 status
lrwxrwxrwx 1 root root    0 Sep  2 16:01 subsystem -> ../../../../../../class/dr

ls -lah /sys/class/drm/card1-HDMI-A-0/

ls: cannot access ‘/sys/class/drm/card1-HDMI-A-0/’: No such file or directory

Contents of /sys/class/drm:

drwxr-xr-x 2 root root 0 Sep 2 16:01 .
drwxr-xr-x 59 root root 0 Dec 31 1969 …
lrwxrwxrwx 1 root root 0 Sep 2 16:01 card0 → …/…/devices/platform/v3dbus/fec00000.v3d/drm/card0
lrwxrwxrwx 1 root root 0 Sep 2 16:01 card1 → …/…/devices/platform/gpu/drm/card1
lrwxrwxrwx 1 root root 0 Sep 2 16:01 card1-HDMI-A-1 → …/…/devices/platform/gpu/drm/card1/card1-HDMI-A-1
lrwxrwxrwx 1 root root 0 Sep 2 16:01 card1-HDMI-A-2 → …/…/devices/platform/gpu/drm/card1/card1-HDMI-A-2
lrwxrwxrwx 1 root root 0 Sep 2 16:01 card1-Writeback-1 → …/…/devices/platform/gpu/drm/card1/card1-Writeback-1
lrwxrwxrwx 1 root root 0 Sep 2 16:01 renderD128 → …/…/devices/platform/v3dbus/fec00000.v3d/drm/renderD128
-r–r–r-- 1 root root 4096 Sep 2 16:01 version

Sure enough, that micro-HDMI to HDMI adapter was the culprit. I replaced it with a Micro-HDMI to HDMI cable and everything is now working. Thanks for the help!


So the ls command output was with the old adapter?

It was; the port folder numbering hasn’t changed with the new cable (it’s still card1-HDMI-A-1 & card1-HDMI-A-2 rather than 0 and 1), but the first HDMI port is now working at 4k.