No SMB server on Vero V in services?

I have all my HDDs mapped as network drives on other PCs in the house so it can easily be accessed and files transferred to it.
After migrating from the 4K+ to the V I figured everything should work since I’m not changing the name from osmc or any credentials, but no luck.
Did some digging around on the V and looking under My OSMC / Services I only see SSH but no SMB.
What am I missing here?

You don’t see this in the app store section?

On my Vero 4K+ yes, on the V no.

I tried to command line it:

osmc@VeroV:~$ sudo apt install samba
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
The following additional packages will be installed:
  python3-dnspython tdb-tools
Suggested packages:
  python3-sniffio python3-trio bind9 bind9utils ctdb ldb-tools smbldap-tools ufw winbind
Recommended packages:
  python3-cryptography python3-requests-toolbelt attr logrotate python3-markdown samba-dsdb-modules samba-vfs-modules
The following NEW packages will be installed:
  python3-dnspython samba tdb-tools
0 upgraded, 3 newly installed, 0 to remove and 0 not upgraded.
Need to get 1249 kB of archives.
After this operation, 17.1 MB of additional disk space will be used.
Do you want to continue? [Y/n] y
Get:1 bullseye/main armhf python3-dnspython all 2.0.0-1 [103 kB]
Get:2 bullseye/main armhf tdb-tools armhf 1.4.3-1+b1 [30.2 kB]
Get:3 bullseye/main armhf samba armhf 2:4.13.13+dfsg-1~deb11u5 [1116 kB]
Fetched 1249 kB in 0s (4687 kB/s)
Selecting previously unselected package python3-dnspython.
(Reading database ... 38091 files and directories currently installed.)
Preparing to unpack .../python3-dnspython_2.0.0-1_all.deb ...
Unpacking python3-dnspython (2.0.0-1) ...
Selecting previously unselected package tdb-tools.
Preparing to unpack .../tdb-tools_1.4.3-1+b1_armhf.deb ...
Unpacking tdb-tools (1.4.3-1+b1) ...
Selecting previously unselected package samba.
Preparing to unpack .../samba_2%3a4.13.13+dfsg-1~deb11u5_armhf.deb ...
Unpacking samba (2:4.13.13+dfsg-1~deb11u5) ...
Setting up tdb-tools (1.4.3-1+b1) ...
update-alternatives: using /usr/bin/tdbbackup.tdbtools to provide /usr/bin/tdbbackup (tdbbackup) in auto mode
update-alternatives: warning: skip creation of /usr/share/man/man8/tdbbackup.8.gz because associated file /usr/share/man/man8/tdbbackup.tdbtools.8.gz (of link group tdbbackup) doesn't exist
Setting up python3-dnspython (2.0.0-1) ...
Setting up samba (2:4.13.13+dfsg-1~deb11u5) ...
Adding group `sambashare' (GID 112) ...
Samba is not being run as an AD Domain Controller: Masking samba-ad-dc.service
Please ignore the following error about deb-systemd-helper not finding those services.
(samba-ad-dc.service masked)
Created symlink /etc/systemd/system/ -> /lib/systemd/system/nmbd.service.
Failed to preset unit: Unit file /etc/systemd/system/samba-ad-dc.service is masked.
/usr/bin/deb-systemd-helper: error: systemctl preset failed on samba-ad-dc.service: No such file or directory
Created symlink /etc/systemd/system/ -> /lib/systemd/system/smbd.service.
samba-ad-dc.service is a disabled or a static unit, not starting it.
Processing triggers for libc-bin (2.31-113) ...
osmc@VeroV:~$ sudo systemctl start smbd
osmc@VeroV:~$ sudo systemctl status smbd
* smbd.service - Samba SMB Daemon
     Loaded: loaded (/lib/systemd/system/smbd.service; enabled; vendor preset: enabled)
     Active: active (running) since Sun 2023-11-19 02:53:09 MST; 57s ago
       Docs: man:smbd(8)
    Process: 5233 ExecStartPre=/usr/share/samba/update-apparmor-samba-profile (code=exited, status=0/SUCCESS)
   Main PID: 5234 (smbd)
     Status: "smbd: ready to serve connections..."
      Tasks: 4 (limit: 3659)
     Memory: 12.3M
     CGroup: /system.slice/smbd.service
             |-5234 /usr/sbin/smbd --foreground --no-process-group
             |-5236 /usr/sbin/smbd --foreground --no-process-group
             |-5237 /usr/sbin/smbd --foreground --no-process-group
             `-5238 /usr/sbin/smbd --foreground --no-process-group

Nov 19 02:53:08 VeroV systemd[1]: Starting Samba SMB Daemon...
Nov 19 02:53:09 VeroV systemd[1]: Started Samba SMB Daemon.

Still not there.

Okay, I went to the app store (shopping cart icon) and installed it again.
Showed up and running in SSH but still couldn’t connect to it.
Did a reboot and now it’s working!

A reboot is sometimes needed for Windows clients to pick it up. I’m not sure why.