No sound after latest updates on Raspberry Pi 3

After watching a movie today I noticed that there were updates available. So I said yes. Went to watch another movie and it had no sound. Thought it might be the movie file. So tried the movie I had watched before the update and still no sound. I’m running a Raspberry Pi 3 connected to a Samsung TV via HDMI. I have no idea where to start. Any ideas?

So sound is via HDMI?

If Sound is via HDMI than the likelihood the update broke it is very slim.
Check that HDMI is configured in the audio settings and also check that Kodi is not muted

Yes, both video and sound has been via HDMI

I’ve checked its not muted and sound is set to PI:HDMI.

First I would power down (disconnect from power) both devices for 2 minutes and then power on TV first before OSMC.
If that doesn’t help enable debugging and upload logs.

I’ve done some more testing and MP4 files play with sound. But MKV files play with NO sound and the video jumps and freezes. Could this have something to do with the codec licenses having a problem after the update?

One of the MKV files I watched before the update worked fine, but now has no sound and the video jumps and freezes,

Well the licences are in the firmware so they are not affected by an update.
What is the mediainfo of the MKV?

Please see the mediainfo section in How to submit a useful support request - General - OSMC