No sound for 'back' action with 5.1 audio

After a long time due to repair, I finally re-plugged my Raspi/OSMC to the 5.1. home theater system.

Everything works well, but if OSMC/Kodi audio is set in 5.1, I can’t hear the ‘whoosh’ sound when doing a ‘back’ action. Other UI sounds like scrolling up and down and selecting an item do work.
Also, I can hear the sound in question if audio is set e.g. in 2.0 mode, and I’ve checked that all 6 loudspeakers work.

Is there some Kodi setting that I should check? I’m a bit puzzled by the fact some UI sound work and some doesn’t, so I don’t see how the cause could be a Kodi setting.


How are they connected?


to get a better understanding of the problem you are experiencing we need also more information from your environment. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

Depending on the used skin you have to set the settings-level to standard or higher, in summary:

  • enable debug logging at settings->system->logging

  • reboot the OSMC device twice(!)

  • reproduce the issue

  • upload the log set (all configs and logs!) either using the Log Uploader method within the My OSMC menu in the GUI or the ssh method invoking command grab-logs -A

  • publish the provided URL from the log set upload, here

Thanks for your understanding. We hope that we can help you asap.

OSMC skin screenshot:

I solved the problem myself, trying the various Kodi audio settings.
It was caused by the ‘stereo upmix’ configuration. When it’s on, that specific UI sound disappears. Keeping it off everything seems to work.
Still, to me it’s really odd that it affected only one sound.

My Raspi is connected via HDMI to the TV (which is muted) and from there it goes to the HT via optical cable.