No sound (HDMI) after start or reboot

Hi all,

I’m having the “no sound” troubles using OSMC with RPi 2.

The HW setup is quite simple, the Pi is connected directly to a projector with built-in speaker using an HDMI cable. The Pi is running a fresh installation of OSMC & Rapsbian (installed using NOOBS). I tried using the OSMC image and it doesn’t make any difference though.

The problem is that I can’t get any sound out of the projector unless I physically reconnect the HDMI cable after OSMC is loaded. Rebooting the Pi (no matter whether it’s over SSH, from the GUI or by physically unplugging the power cable) means I need to do the procedure again.

I tried a lot of the general guidelines (e.g. http://elinux.org/R-Pi_Troubleshooting#Sound_does_not_work_with_an_HDMI_monitor), neither of which worked. I also experienced this problem with OpenELEC (v. 6+, v. 5 worked fine). On the other hand, Raspbian has worked and still works fine.

The included logs show the boot process, opening a YouTube video (no sound), stopping the video, unplugging and reconnecting the HDMI cable and playing another YouTube video (sound working fine). The logs can be found here : http://paste.osmc.io/siyugopoti.

Any thoughts on how I could get the sound working right away?

What does tvservice -a report?

PCM supported: Max channels: 2, Max samplerate: 96kHz, Max samplesize 24 bits.

One more finding: the sound also goes away whenever Kodi is restarted.

@danstahr did you find a fix for this? I started having the same problem on one of my raspberries.