No sound on atv1 with OSMC usb stick

Over the weekend I created a new usb stick with the latest OSMC. Everything went successfully and I was streaming a movie when halfway into the movie the sound went off. I checked all the settings and even reset the audio under system-audio output. I then set it for hdmi and even rebooted. But no sound at all. Even when navigating the menus there is no sound. I then shut off my atv1, replaced the usb stick with the previous one on which I had crystalbuntu. Sound is back. Replaced usb stick with the new one which has OSMC and no sound.
ATV1 has crystal HD chip installed in it.

Update: So I took the usb stick with OSMC and formatted again and downloaded and installed OSMC again on it. Placed it in ATV1 and sound is back. Have not streamed anything yet but will inform if sound stays or goes away again.

I had a no sound problem on my atv1 and followed these steps to fix it (Not sure who to thank for it - found it in a search but don’t remember where)

Anyway, SSH to your box and enter this command:

amixer set Master 100% unmute > /dev/null 2>&1

Hope this helps


The analog volume is too low. This command helps to turn it high!! Thanks!!

Thanks. I just made the usb stick again and that fixed it.

Hi Michelb,

How do I SSH to my Apple TV1? I too am having this same issue where I’ve lost all sound.

Any help would be great.


SSH is a communication protocol to connect to different computers (kind of like FTP or HTTP or telnet) and you need to use software to use it. “PuTTY” is a popular, free one that I use but there are many different ones available. When you connect, you need your login / password which might depend on how you broke into your ATV (I think some of the popular methods set it to “root/alpine” or “atv/atv” or “frontrow/frontrow”.

Hope this helps,

Thanks for the response Michelb. I followed the instructions on the osmc website to install the software onto my Apple TV 1. I’m using the usb method to boot. I’ve downloaded cyberduck onto my Mac but had no luck with all those usernames/passwords you suggested. I also tried again using terminal and SSH but connection refused them all also.

Any suggestions :slight_smile: ?

user: osmc
pass: osmc

Thanks cybero2912, that worked! once logged into the box, it ran a few updates. Then I used the line of code to adjust the mixer volume but nothing changed. See below from terminal.

The programs included with the Debian GNU/Linux system are free software;
the exact distribution terms for each program are described in the
individual files in /usr/share/doc/*/copyright.

Debian GNU/Linux comes with ABSOLUTELY NO WARRANTY, to the extent
permitted by applicable law.
Updating APT cache. Please be patient.
Generating locales (this might take a while)…
en_AU.UTF-8… done
Generation complete.
osmc@osmc:~$ amixer set Master 100% unmute > /dev/null 2>&1

how is the ATV connected to your TV?
mine is connected through HDMI and I have no problem with the sound.
If yours is also connected through HDMI check your Kodi audio settings