No sound when playing music

No sound when playing music. I use a Vero 4K+.
I moved all my media to a new server. In OSMC I changed the path for the new server and updated the libraries.
When I play a movie, there is sound.
When I play music I have no sound.
When I play music (FLAC), there is no sound. I changed to sound other music formats, but they have no sound either.
When I play these file on my laptop, there is sound.
I copied some files to a thumb drive and put it direct in the Vero. Still no sound (on different formats).
I did a clean install whit the latest version of OSMC (20220918) and no sound.

Any ideas?
Thanks Harry

Some more info:

My Vero 4K= is connected to a Pioneer SC2024 AVR. By a HDMI cable.

The OSMC remote and a thumb drive are connected to the Vero.

I put the log file here:


The playback of music worked in the past. I don’t recall how long ago I used it. Could be a year.


weekend update:

I did some trails:
When i install a clean 2021.12-1 image, i have sound when i play music.
After an update this is not working any more

When i install a clean 2022.03-1 image, i have sound when i play music.
After an update this is not working any more

When i install a clean 2022.09-1 image i have no sound when i play music

When i install a clean 2022.10-1 image i have no sound when i play music

I all cases i have sound when i play movies. And i all cases i played the music and movies from both the server as from the thumb drive

If i have no sound when i play music i also have no GUI sounds any more

Ideas anyone?



Is the audio settings the same after the update. I’m a bit confused on what settings I saw in the logs you had posted. You had HD audio formats and AC3 transcoding enabled but passthrough (which is what enables them) turned off. Also on your player settings sync playback to display should not be enabled.

What happens if you set your channels to 7.1, disable transcoding, and enable passthrough for everything else?

The channels set to 7.1 and passthrough enabled, transding disabled gives no sound when i play music

In each case, did you restore your settings before updating?

If you

systemctl stop mediacenter
mv ~/.kodi ~/kodibak
systemctl start mediacenter

do you get GUI sounds and music back?

I did the following:

clean install 20220.03-1
added NAS drives

sound when i play music and GUI sounds

restore the settings as above

no sound and no GUI sounds

And if you change audio channels to 2.0? And if that works are you sure the Vero is plugged into the AVR and not the TV. I’m scratching my head on this one. I pulled your guisettings.xml into my setup and can’t reproduce a problem. Does it make a difference what format of audio file (stereo or multichannel FLAC, mp3, m4a, etc.)?

If I use 2.0 or 7.1 that does not make any difference.

The Vero is connected to the AVR by HDMI. This TV is connected to the AR as well by HDMI. If the AVR is off, media of the Vero can be played. The AVR has a pass trough.

I trans coded some music files to different formats, with no success. They were all stereo.


Admittedly – this one seems to have us puzzled (myself included).

Are you using a Bluetooth remote to control your device?
In the log that you uploaded – did you try and play a file? I didn’t see an attempt here.



I’m not using a Bluetooth remote. I use the OSMC remote and a app on my phone.

About the log: I do not recall if I try to play a file first and than make the log. But I can make one if it helps.

Would it help when I make 2 log files: one before an update (when I can play music) and one after the update? And then compare them?


That would be great. Please make sure debugging is enabled for both.


This is my order:

clean install 2022.03-1

enable debug log

play music

upload log:



play music

upload log


I hope this can solve is issue

cheers Harry

First thing I notice is your Pioneer AVR isn’t advertizing 7.1 channel capability in its EDID. And you have set channels to stereo only. Is there something we should know about your AVR? Was it off when you grabbed these logs?

the AVR was off when i made the losgs

OK but was it off when you tried to play the track?

As a test, can you set the audio output to Fixed and 48ks/s?

1 Like

When i set settings ==> system ==> audio ==> output configuration to fixed I have music and GUI sounds.

I can turn it on and of with this setting, also after reboot.

So this did the trick



Thanks for confirming. It’s not a solution for those with ‘golden ears’ but a workaround while we figure out why 44.1kHz audio doesn’t work with certain setups. It’s reproduceable when video is 4k but now we know it can happen with 1080p video as well.