No sound/white noise on Kodi 19


I am using a Vero 4K+ and just updated to Kodi 19. I am not getting any sound played on every single movie. Either there is no sound at all (on 7.1 files as far as I could observe) or there is heavy white noise (2.0 and 5.1 files). System sounds work good however.

Passtrough for all formats is activated which worked fine before the upgrade.

Device is a Samsung HW-Q90R, cabling is via HDMI.

Every help is appreciated, thank you!

Logs please! That will help us see your settings.

To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

Depending on the used skin you have to set the settings-level to standard or higher, in summary:

  • enable debug logging at settings->system->logging

  • reboot the OSMC device twice(!)

  • reproduce the issue

  • upload the log set (all configs and logs!) either using the Log Uploader method within the My OSMC menu in the GUI or the ssh method invoking command grab-logs -A

  • publish the provided URL from the log set upload, here

Thanks for your understanding. We hope that we can help you get up and running again shortly.

OSMC skin screenshot:

Thanks for the info. Here you go:

Unfortunately I got a sad face when uploading in the first place. I hope the necessary information is included.

GUI Resolution: 3840x2160 @ 60p

You should set this to 1080 @ 60p. Using 2160 is not recommended.

In case you are wondering, there is an obscure bug affecting audio when the screen is set to 4k.

Can you try turning off ‘Stereo upmix’ as well?

Disabling “stereo upmix” did the job! Thank you.

However, setting the screen to 1080@60p leaves the OSMC screen “zoomed in”. It is slightly larger than the TV now. I tried rebooting the vero4k+ and removed the power for some minutes from the home cinema system, but still the menu doesn’t fit the screen.

Disable overscan on your TV. Setting is Just Scan or 1:1. If you let us know your brand/model we can help

I got that one. :slight_smile:

Thanks a lot!

I had the same problem everything working fine on audio before Kodi19 now no stream on most audio or white noise I turned off stereo upmix as advised and it did the trick audio back to normal now.