No space on root


I’m really stuck, and about to rebuilt my 4K+; as a last step before I do this I thought I would through out a post for help.

I know enough about linux to be dangerous, I’m hoping that someone out there which knows more than I do might like to share their knowledge.

I appear to be using all my space in /.

In the past when this has happened I’ve found that the /mnt local mount points are full of files because the os couldn’t assess my NAS. I fixed the problem by unmounting and using ncdu to delete local files in mount (following by adding the auto mount thing to my to-do list, which I never get round to doing).

In this case, I’ve unmounted all my mounts just to make sure the directories were’t filling up locally.

When I run ncdu / I can’t see the culprit in /mnt.

When I look in /mnt my tvrecordings directory has some unusual permissions, and I think this might be the problem.

Here are some clues to the puzzle. Please please gentle with your commentary on my (emerging) linux CLI skills … :slight_smile:


Commands I’ve tried. You can see my poor attempts to fix … combination of a few google searches and a bit of guessing and trying to remember basic linux fs commands.

I’ve also tried fsck -cy as I thought it could be corrupt fs.

Suggestions on how I might delete what I think is the offending directory very much appreciated.

Cheers, Geoff

  1. Normally, things under /mnt are mount points. What’s the output of the command mount?

  2. What makes you think that /mnt/tvrecordings is filling up the root partition?

  3. One of the error messages said that /mnt/tvrecordings is busy. You need to stop mediacenter and TVH (and anything else that might be accessing it), then you should try sudo umount /mn/tvrecorddings Then run df.

  4. Often it’s Kodi-related stuff in /home/osmc/.kodi that’s the problem. So, depending on the result of 3, you might want to run du -s /home/osmc/.kodi.

  5. Finally, please don’t post images of SSH sessions. Instead, copy/paste the text and format with the </> button.

thanks for reply, suggestion #3 did the trick.

Cheers, Geoff.

That’s a rather cryptic reply. Was it stopping mediacenter / TVH / whatever that did the trick or did you also umount it? And, of course, was /mnt/tvrecordings the culprit?

yes, i had to stop processes and unmount, then i could delete local files in /mnt/tvrecordings.

Root cause was NAS NFS permissions weren’t updated with new LAN IP address range which new router issued.

Cheers, Geoff.

1 Like