No ssid listed on wifi after last update (Rpi3)


After the last October update, I can’t list and connect to the wifi via the osmc interface on my raspberry pi 3. I use the internal transceiver (no dongle).
I tried some solutions (most apply on other versions of raspberry) but nothing works.

Here are the logs:

I connected the raspberry through wire, I logged in via ssh and tried to configure it, but now I’m stuck.

The connection is UP, I tried “iwlist” and the different ssid in the neighborhood are listed, but nothing appears in the osmc interface.


please try via ssh:

sudo rm -rf /var/lib/connman/wifi*
sudo reboot 0

Hopefully ssids should now be listed in MyOSMC.

Thanks Tom.


Thanks Tom! I tried but still nothing in the list.
“iwlist” still gives me a correct list

Just a guess but it could be related to the wicd* and python-wicd packages you’ve installed. If possible, remove them, reboot and see if that fixes things.

I removed them, reboot and the problem is still the same.

Could you provide more logs? The problem could be different this time.

I can, but which one?
The previous log already comes from “grab-logs --all”.

If you want to see a log which is not already grabbed, be more specific.

Same logs just after removing the packages

Here are the updated logs:

All that nl80211 messages are strange

Oct 21 21:20:44 osmc wpa_supplicant[313]: nl80211: Failed to open /proc/sys/net/ipv4/conf/p2p-dev-wlan0/drop_unicast_in_l2_multicast: No such file or directory
Oct 21 21:20:44 osmc wpa_supplicant[313]: nl80211: Failed to set IPv4 unicast in multicast filter
Oct 21 21:20:45 osmc wpa_supplicant[313]: nl80211: deinit ifname=wlan0 disabled_11b_rates=0
Oct 21 21:20:45 osmc wpa_supplicant[313]: Note: nl80211 driver interface is not designed to be used with ap_scan=2; this can result in connection failures

First, I suggest that you purge the wicd* packages. Second, python-wicd is still installed (also purge). Next, run autoremove, then reboot.

Same problem and same messages in the logs:

You have tethering enabled on WiFi. I’m working from memory but to disable it should be something like connmanctl tether wifi off. Last time I looked, tethering wasn’t working in the 4.19 kernel.

Ok, it wasn’t clear that tethering was enable.
I disabled it and now I see a list of ssid in the list but I can’t connect.

I can’t try more test now but I will repost a new log asap.

Ok, now it works. Thanks a lot.

I still don’t know why the tethering was activated with the last update. I will try to remember next time.