No switch to 4K

Hello all, what can be the reason, that 4K videos are now not played back in 4K. This has worked in the past. I have not used the Vero 4K+ for a longer time, may be even not after the March update.

If I change the Interface resolution the TV indicates 4K, but I know this is not recommended and everything is very laggy.

To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

Depending on the used skin you have to set the settings-level to standard or higher, in summary:

  • enable debug logging at settings->system->logging

  • reboot the OSMC device twice(!)

  • reproduce the issue

  • upload the log set (all configs and logs!) either using the Log Uploader method within the My OSMC menu in the GUI or the ssh method invoking command grab-logs -A

  • publish the provided URL from the log set upload, here

Thanks for your understanding. We hope that we can help you get up and running again shortly.

OSMC skin screenshot:

hi, the URL is:

The video your playing is 50fps and your TV is not displaying support for that frame rate at 4K resolution so Kodi is prioritizing smooth video over higher resolution. If you configured a white list you could go into the video settings during playback and override this, but I don’t suspect you would find it to be a preferable viiewing experience.

Thank you for your answer, but this is strange.

I haven’t changed any hardware component since I bought the Vero 4K in 2020. And there are several files in UHD and 50fps which have been displayed correctly in the past.

I tried the whitelist, but UHD with 50fps is not in the list, highest value is 30fps.

In the specification of the TV also 3840x2160@60p is listed.

Maybee I changed a minor thing like HDMI cable or port, could this be the root cause?

The supported formats of your TV come from your TV as you can see in the log…

====================== Display Cap CTA =================== g0gjk991

---------------------- Display Cap CTA END --------------- g0gjk991

Perhaps your TV did a firmware update and that changed something. Perhaps what you played previously wasn’t 50fps but 25fps which your TV reports as being supported.

The list is only what your TV is reporting as supported. What I meant was that you could force it to something like 2160p25 which would give you the resolution at the cost of a correct frame rate.

A change of cable no, a change of ports might not be outside the realm of possibilities. If ports on your TV had different specs this should be outlined in the user manual for the TV.

For sure the videos (I made them myself) have always been in 50p, but of course a firmware change of the TV is possible. Today I made a firmware update, but still the same behavior. At the TV a firmware downgrade is not possible.

Is it possible for test purposes to went back to the firmware of mid 2020 for the Vero?

Found it out myself, but as expected it doesn’t work also with a previous OSMC version.

This would imply a TV change or a different environment change such as AVR.

If your sure your TV supports 2160p50hz input it is possible to manually make an override to what your TV is reporting as supported…

Hi all, thank you for your support. I tried the manual override and added 2160p50hz. After that the TV shows when the playback starts: 3840x2160@31Hz. Around 30 seconds everything went well, but after that the playback has interrupts. So it seems that I have to accept, that my TV no longer is able to playback 4K@50Hz. Maybe I contact Sony why they made this change. (@sam_nazarko: my last hardware change (TV, AVR really everything) was the vero in early 2020 and I have watched my videos until early 2022 in in 4K@50Hz)

1 Like