No video output after extended idle period

I’ve been using OSMC on Raspberry PI 3 B+s for about 6 months now. They’ve been absolutely solid this whole time. I always leave them on, since they are such low powered devices. I just recently decided to get an additional RPi for the last and final TV. With the new Pi I’ve noticed an annoying behavior. The new RPi is connected to a Pioneer receiver that does get turned off between uses. I’ve noticed that after an extended period of idle time it will no longer output any video to the receiver and I have to power cycle the RPi to get it to display video again.

The two preexisting RPi’s that I’ve had for the last 6 months have been solid and I’m assuming that it has to do with the fact that those two are directly connected to their respective TVs. Whereas the new RPi is only connected to my receiver which in turn outputs to a projector. Is there some sort of setting to disable or adjust the video output idle time?

Thanks for any help.

I should also point out that the shutdown function timer in the Kodi System settings is disabled.

Hi,
Just a guess looking at Video options in config.txt - Raspberry Pi Documentation - could " hdmi_force_hotplug=1" be a solution?
Regards
/L

I think you could try this… While the pi is actually giving you a good display-
sudo /opt/vc/bin/tvservice -d /boot/edid.dat

and add hdmi_edid_file=1 to config.txt. Now the pi will know what the good display configuration is even if it cannot see the available modes.

2 Likes

El_Grincho,

Thanks for that suggestion. I’ll take a closer look at it. That looks like a really good reference.

ActionA,

Will those changes persist between reboots?

Also, once I apply those changes to the config.txt file is there any need to reboot or do anything for the changes to take effect?

Hi,

Yes

Reboot will be required as config.txt is read at boot up.

Thanks Tom.

Okay, so I actually applied the changes suggested by both El_Grincho and ActionA and then rebooted. And it looks like it’s still happening.

I have discovered though that when there appears to not be any video, I can press an arrow key on my remote and hear the interface sounds. So this tells me that audio is still crossing the link but it’s simply video that is not. I’ve also discovered that if I just change the source on my receiver to something else and then go back to my RPi then the image comes back. It seems it needs to perform the HDCP handshake all over again before picture comes back.

I’m still not sure if any of that information is useful but would you happen have any additional suggestions? Thanks again for your help.

Hi,

At this point, I would suggest uploading some logs, details can be found here:

How to submit a useful support request - General - OSMC

Thanks Tom.