No Wi-Fi connection after update

Sure.
https://paste.osmc.tv/uforivusix

I don’t have this dongle but there’s an error message in the log:

mt76x0 1-1.4:1.0: Direct firmware load for mediatek/mt7610u.bin failed with error -2

I can’t find a file /lib/firmware/mediatek/mt7610u.bin on my RPi but one does exist in /lib/firmware.

If the file exists in /lib/firmware on your system – which it should – create a mediatek directory and copy mt7610u.bin into it. Then reboot.

It looks like the 4.19 driver for MT7610U expects the firmware in a slightly different place. @apb0703 - can you confirm if this resolves the problem? I will be able to push a fix quite promptly if this is indeed the case.

Sam

I see quite a few topics regarding this issue and probably it’s better to paste the log here
https://paste.osmc.tv/ifafupefaj

Can you try this via SSH:

sudo mkdir -p /lib/firmware/mediatek
sudo cp /lib/firmware/mt7610u_sta.template.dat /lib/firmware/mediatek/mt7610u.bin
reboot

Otherwise, I can check this in a couple of hours.

Sam

Edited by dillthedog

@sam_nazarko Tried that but nothing changed,also please edit your post , because it might confuse anyone not experienced enough with Linux folders etc.

https://paste.osmc.tv/dapukemice

I am on hostapd based setup and for me its exactly an opposite issue :slight_smile:
External USB card works, but internal (RP3 built-in wifi0) does not.
Seems hostapd is not fully compatible with the new kernel:

nl80211: interface wlan0 in phy phy1
nl80211: Set mode ifindex 4 iftype 3 (AP)
nl80211: Setup AP(wlan0) - device_ap_sme=1 use_monitor=0
nl80211: Subscribe to mgmt frames with AP handle 0x18ec0c0 (device SME)
nl80211: Register frame type=0xd0 (WLAN_FC_STYPE_ACTION) nl_handle=0x18ec0c0 match=
nl80211: Register frame command failed (type=208): ret=-22 (Invalid argument)
nl80211: Register frame match - hexdump(len=0): [NULL]
nl80211: Could not configure driver mode
nl80211: deinit ifname=wlan0 disabled_11b_rates=0

Tried the suggestion above. Did not work. I am getting no lights from the dongle. It is almost like after the update it bricked.

You need to be a bit more specific. Which suggestion?

Please provide logs again.

Sam’s suggestion

You’re getting this in the log:

Nov 02 20:52:16 osmc kernel: mt76x0 1-1.5:1.0: Invalid firmware image

What’s the output from running md5sum /lib/firmware/mediatek/mt7610u.bin

There was a mistake in Sam’s post, which I’ve edited. Please re-read and try again.

1 Like

I’m checking this now - as the path shouldn’t have actually changed…

Please provide full logs: grab-logs -A

Update: It looks like it might be a kernel-related issue

I had previously used rpi-update to update the installed kernel (to 4.14.90-v7+). When I revert back to the stock kernel (4.14.79-v7+), things work as documented.

FYI, the previous OSMC kernel was 4.14.78-4.

Also see:

https://www.raspberrypi.org/forums/viewtopic.php?f=29&t=224931&start=25#p1396409

Unfortunately the hostapd 2.4 shipped with Raspbian Stretch failed with Linux 4.18 and newer

It seems that you need version 2.7, which ships with Debian buster.

e19e5a7b22e798e3d2997a09cdb86a40  /lib/firmware/mediatek/mt7610u.bin

Hi
Thank you, that is what I’ve found as well.
I’ve solved the issue by adding stretch-backports to sources.list and forcing install the newest version of hostapd (Version: 2:2.7+git20190128+0c1e29f-4~bpo9+2)
Thanks for support

1 Like

Running of Rasberry-Pi.
Just performed latest update and there is no longer any network connection (wi-fi).
There is also no “my-osmc” to try to fix it.

All I have are the standard “System” menu items.
System->System Info->Network says nothing connected, and check network settings.
A bit hard to do since those are in “my-osmc” and it has vanished.

Looks like I may be facing a re-build???

Moved your post here, depending on your WiFi dongle you would not need to reinstall

The alternative place to find the MyOSMC app is setting>add-ons>My add-ons>program add-ons>MyOSMC

Aside from that fixing your issue you have not given us enough to help you here. Logs would be a good place to start.

https://osmc.tv/wiki/general/how-to-submit-a-useful-support-request/

No dongle. Built-in. Was working perfectly before the update.