No Widevine Playback Across OSMC

@FaustoGSR I have Widevine version 4.10.2557.0 installed currently.

mmm interesting. I wonder why with dazn the same dll doesn’t work for me anymore but the old 2449 yes.

i wish it is the addon that does not resolve correctly all flux for correct stream.

Current logs:

I’ve tried several rounds of uninstalling Widevine and add-ons, rebooting, and reinstalling with no luck. I’m out of ideas on how to fix.

Here’s the Widevine process as I know it:

  • Install Widevine through InputStream Helper
  • Use SlyGuy Common service to switch between versions if necessary

Are there any other steps I’m missing or anything specific to the RPi 2 that I should be doing?

Edit: this did not do anything for this case:

Nothings it’s that only found the right combination of Inputstream.Adaptive (the mpeg-dash component) and the widevine dll.

If i understand correctly on kodi 20.x the Inputstream.Adaptive can be upgradable like a normal addon instead on osmc this it’s built-in whit the os.
as of today I don’t know if osmc uses the latest version of this component…

Is InputStream.Adaptive something I can update manually in OSMC?

InputStream.Adaptive definitely seems to be the problem. This shows up in the log when I try to start a stream (Hulu and Amazon VOD):

inputstream.adaptive returned bad status "Permanent failure" during instance creation

These logs show it after stream initiation:

@eggbeater about inputstream.helper are you already check if osmc use already last available version?

i have check my kodi.log it’s say:
inputstream.adaptive v19.0.7 installed

for matrix apparently yes…

@FaustoGSR According to the log I’m also using v19.0.7

Interestingly Widevine playback started working again yesterday. The only change was Amazon VOD updated to 0.9.7. Maybe that was it?

but you had tried with other videos that required the libraries widevine?
if i remember on slyguy repo there’s exist an addon contain some sample video link to test if the mpeg dash and widevine work…

Yes, I had. Almost all the addons I use require Widevine. When it stops working for one addon, it’s down for all of them.

Oddly enough, this just started happening again tonight. It’s been working great since it began working again in my last post until tonight when my Pi froze up with both green and red lights staying solid. I unplugged the power and plugged it back in. Then the error message appeared yet again. I rebooted to no avail.


I ran the OSMC May update but Widevine content still doesn’t play.

it’s work… I am now watching an event on dazn and it’s work.
you have to check your addon (if i understand amazon vod) it’s completely and fully work.
it’s not widevide your issue.

I’ll check on it, but Netflix and Hulu aren’t working either.

I’m glad it’s working for you though! May I ask, which Kodi skin are you using?

For reference, this is the message that appears regardless of the add-on:

i don’t thinks skin can interfere on widewine…
anyway in my case i use the actual estuary mod v2 from kodinerds repo.

anyway about your screenshot… this error it’s very generic error and it’s related and appears also when from an addon you try to open something and the stream it’s not anymore online or it’s deleted.

i can only confirm to you… current widevine work and i thinks if you obtain some trouble you need to investigate in other side. the question it’s where ?