No Widevine Playback Across OSMC

I ran a semi-routine sudo apt full-upgrade and Widevine update yesterday on my RPi 2 with the January 2023 OSMC update. After that, my Pi won’t playback any Widevine content. I’ve tried reinstalling every version of Widevine through InputStream Helper and the SlyGuy method with reboots in between each version to no avail. I’m out of ideas at this point.

Attached are my logs of attempts in Amazon and Hulu:

Please let me know if more information is needed. I love OSMC and it’s a fantastic product. I’m bummed to have borked it.

Thanks in advance for any assistance!

Updated logs:

I added the packages mentioned in this post in the Hulu thread even though I never had them installed previously.

sudo apt install python3-pycryptodome python3-cryptography

I was able to play Widevine content without them before. Unfortunately, adding the packages has not altered the situation.

I don’t know what the issue is unfortunately.

Maybe some others can confirm if their Widevine on PI is working and we can compare logs.

Could you try with a new install?


1 Like

I can try with a new install. It might be today or tomorrow. I just need to back up my skin preferences first!

Great, keep me posted.

I just accidentally discovered that playback works (with SlyGuy addons) when using the default OSMC skin. I’ve been using the Eminence skin.

When attempting to playback from the Prime Video addon, I was prompted to update Widevine. I’m running that now.

Let us know but things should be working…

I apologize for the hype…it doesn’t work again. I will reinstall tomorrow as I should have and report back.

Sam, you have the patience of a saint!

the only dll you can use for widevine it’s available here.
armv7 version for the pi2.

you have to put this on cdm folder manually and rename to “”

after you use inputstream helper to install latest widevine you need to put one of dll picked from upper link.

Thanks for the advice. The instructions on Widevine seem to change all the time!

Thank you @FaustoGSR. I haven’t had time to keep up with the constant changing world of widevine.

no problem… i follow the widevine because i use that whit my account and current addon for Dazn italy.
personally, if i remember correctly i use the 4.10.2449 because if try to update to 4.10.2557 every stream goes in buffering.
whit 4.10.2449 i need to manually select the livestream to 720p but above check that the video stream does not have a bitrate that is too high (i thinks the hardware it’s fault to decrypt and it’s start to buffering)

with a Pi2, that is probably true. And this is just a wild guess, but it think having issues where 720 has to be set manually, is that the stream defaults to 1080, if no explicit client settings is sent to the provider, like if you have not set 720p only, kodi will say it will handle 1080p no problem, which the stream provider takes as parameter to send in that resolution, making it hard for the pi2 to keep up.

Salutations! I’m sorry I didn’t report back sooner. I had success with reinstalling OSMC. I installed Widevine through InputStream Helper and got SlyGuy’s Hulu add-on to work. I haven’t tested Amazon VOD or Netflix yet for various reasons. However, I’m confident that the reinstall fixed the problem.

Lesson learned (again): if it ain’t broke, don’t fix it!

I will report back once more after copying over my skin settings so I know the problem is certainly resolved.

All indeed works well again after re-applying my skin settings. Thank you everyone for your input and to @sam_nazarko for the ultimate solution. Thank you for curating such an amazing media center!

can you specify, for purpose test, what exact version have you, right now, on your kodi?

about 30 second ago, from dazn addon, i have start to watch italian serie a match Milan - Lecce and immediately i obtain the video streaming completely in struttering and no audio.

i have open my cdm folder (/home/osmc/.kodi/cdm)

and i have need to step back to and use the dll 4.10.2449 and all back to work normally.

can you provide your positive feedback?

I have 2023.1 OSMC with Kodi Matrix 19.5 on a Raspberry Pi 2 B.

Unfortunately the original issue cropped up again last night and I can’t play Widevine content anymore. I did nothing out of the ordinary this time. I need to look into the above responses about DLLs (didn’t know DLLs were a Linux thing too) since I never had to worry about that before. I don’t want to have to do another reinstall again.

ops sorry… request the specif version of widevine dll not the main os.

.dll could “lousily translate” to .so files in Linux, from Lifewire article.

What does a .SO file do?

What Is an SO File? A file with the . SO file extension is a shared library file. They contain information that can be used by one or more programs to offload resources so that the application(s) calling the SO file doesn’t have to actually provide the file.

or from Stackoverflow

What is the difference between .so and .a file?

A .a file is a static library, while a .so file is a shared object dynamic library similar to a DLL on Windows.

Hope that helps

1 Like