No wired connection after reboot

I just got my RPi 3 and I installed osmc on it. Everything works great, except that after each reboot I lose wired connection (I don’t use wifi). The only way to fix it is to take the cable out and put it back in.

Logs: pastebin

Hi,

could you repeat the logs collecting and this time keep the sequence 1) setting debug flags, 2) reboot, 3) reproduce the issue and 4) upload the data as described here: http://osmc.tv/wiki/general/how-to-submit-a-useful-support-request/

  • Is it a fix/manual IPv4 configuration setup?
  • Have you checked for duplicate IP addresses, first?

Thx,

I’ll post the logs in a few minutes, when I access to it (as an edit to this post).
As for your questions: It’s manual IPv4 config and I made sure there are no address conflicts
Edit: https://paste.osmc.tv/iverenurag

The log shows this message sequence:

sty 30 17:26:03 TV connmand[260]: eth0 {add} address 192.168.1.222/24 label eth0 family 2
...
sty 30 17:26:09 TV connmand[260]: Online check failed for 0x5590b000 Wired
...
sty 30 17:26:27 TV connmand[260]: eth0 {del} address 192.168.1.222/24 label eth0
...
sty 30 17:26:30 TV connmand[260]: eth0 {add} address 192.168.1.222/24 label eth0 family 2

You don’t tell us how long you wait before removing the cable, so it’s not clear if the “Online check failed” is caused by you or by something else.

I fear we need a more detailed problem description. What is/are the concrete symptom(s) that you mean you have lost connection via the wired network interface?

@dillthedog I waited about 10 seconds (starting when I saw the UI) before removing the cable.

@JimKnopf

  • I can see the connection in my router’s controll panel
  • I can’t access any samba shares
  • Kore (the remote controller app) doesn’t see it
  • Trying to ping it from my PC says either “destination host unreachable” or “connection timeout”
  • The PI cannot access anything on the Internet, nor can it see any network shares

All these issues are resolved when I unplug the cable and plug it back in.
EDIT: Just to clarify: I have these issues ONLY after a reboot

Well, from the log the NIC has got 192.168.1.222, link is up, but no internet connection … till you pulled the cable and the interface goes down.

  • What router is this?
  • Is the ip within the range of non-DHCP addresses?
  • Are there any other network components between the Raspberry and the router? How looks your network topology?

Router comes from my ISP. It’s called “Funbox 2.0”, the only other info I have is that it’s made by Sagemcom. DHCP is set to go up to .200. The Pi is connected directly to the router with 15 meters of cat5 ethernet cable. Almost every other device is connected with wifi

The IP address is .222. So is this a static address?

Some other strange things in the log (mainly for reference, since I’m not sure what the problem is):

sty 30 17:26:04 TV systemd[1]: Started Wait for Network to be Configured.
sty 30 17:26:04 TV systemd[1]: Reached target Network is Online.

Normally OSMC will try to communicate with IP address 159.253.212.250 at startup but couldn’t get through until you pulled the cable. So the two messages above suggest that connman thinks it’s online but somehow it isn’t able to “ping” the OSMC IP address.

Yes, I set the static address manually. As for that IP OSMC tries to ping, I can ping it no problem from my PC, and from my PI no problem. Can you tell me, why it is pinging it?

Looks to be a simple test to determine whether the internet can be reached.

What happens if you let request the Pi an IPv4 by DHCP from your router?
Is there any special role/function of the used ports of this router?

I’ll try that in the morning. Currently, there are no roles or functions on the Pi, other than osmc, but I plan on installing pihole on it, so I figured a static IP would be usefull for that

You need to be careful. PiHole is not very compatible with OSMC. For example, it installs dhcpd5 and tries to set a static IP address in /etc/dhcpd.conf. This is incompatible with ConnMan.

Thanks for the warning. I read somewhere (probably on this forum) that they work fine together, although that info might be outdated.

Back on the original subject, it’s possible that the router is the problem. (ISP-supplied routers can often be poor quality.)

You say that the IP address is manually set, but that could be done either on OSMC or on the router. If it was manually set on OSMC, it might be worth setting OSMC to use DHCP and then set a static IP address on the router for the Pi’s MAC address.

When I set Pi to use DHCP and I set the adress on the router, nothing changes.

However, when I set it to DHCP and I don’t set any adress on the router, it gets the folowing configuration:

  • IP: 169.254.252.218
  • Subnet: 255.255.0.0
  • Gateway and DNS: empty.

Removing the cable and putting it back in does NOT fix it this time. Also, now when I try to set the Pi to DHCP it keeps switching to manual config with everything blank and shows “Status: eth0 (configuring)”.

Suprisingly, when I connect to my wifi it gets the IP no problem. Rebooting does not break anything. I’ll use wifi for now, but I would really prefer using wired, because there is about 20 other networks that interfere with mine and I already have the cable bought specifically for that.

169.254.252.218

is a zeroconf address; this happens if a device tries to get a DHCP address but nobody answers on the request.

Well, the problem seems to be related to your router and/or the cable since it is not doing what it should. I fear that we cannot help here too much. I do not want to make any fingerpointing but letting google translate some Polish forum web sides shows to me, that this “Funbox 2.0” isn’t a good router at all.

If this would be class problem with the Pi3 and OSMC, this forum would be full of threads like yours … but it isn’t. Perhaps, you try it with some other LAN cables assuming the router has some auto MDIX issues but this is pure specualtion. Also, to place a network switch between the Pi and the router would be worth a try assuming there is some autonegation issue regarding the speed.

The router is crap. They do have another model that is actually good, but it’s only available if you have fiber, which I have no access to (Yay for living in a small town with a ton of cables from the 90s underground). So far it seems like the cable is the problem. I’m going to try and convert my old tl-wr543g router into a switch and see how it works out.

EDIT: Success! I managed to convert that old router into a switch (which was easier than I thought) and now it looks like everything is working. Now I just have to figure out if I made the plugs incorrectly (which I can fix), or if I bought faulty cable (which I can’t do anything bout).

Thanks for all the help.

1 Like