No wired connection on new RPi3

I hope someone can help.

I have a brand new Pi3 with OSMC installed. All seems to be working except wired (ethernet) connection. WLAN connection is fine, but wired will not connect with DHCP or Static address.

I’ve checked the following:

  1. Lights on ethernet port are blinking
  2. Cable is ok, checked with another device.
  3. Power supply was a 500mA unit supplied with the kit, I have upgraded it to 850mA unit just in case it was a low power issue but no difference.
  4. When the Pi is set to DHCP, my router’s logs show that it is attempting to supply an IP lease, but the confic screen on OSMC just shows "Status: eth0 (configuring), but nothing else happens.
  5. If I manually assign an IP, it shows up on my router for a bit, but I can’t ping it from another device, and eventually I get Status: eth0 (not connected) and it disappears from my router’s connection table.

What could the issue be?

If it’ll help, logs are here: (this will show that eth0 is disbled, 'cos that was the only way to get internet access through WLAN. - That isn’t the problem)

It IS a low power issue: recommended PSU capacity for RP3 is 2,5A.

1 Like

I’ve upgraded the power supply to 2.75A. No change in symptoms.

I can see the DHCP discovery request and DHCP offer on the router log. But Connection manager is stuck on “eth0 (configuring)” After a while -20 minutes or more -it reverts to an internal IP (169.x.x.x; sub

If I allocate a static IP in my local range, router can ping for a while but there is no internet access. Then it just says ‘(no connection)’, and router can’t see it.

There must be something simple that I’ve missed.

Are you trying to connect to WLAN and LAN simultaneously?

No. I’ve disabled WLAN completely.

FWIW, WLAN works perfectly without issues (but is quite far from AP, so a little slow, I’d prefer wired for speed and stability)

1 Like

Try another cable and/or another port on your switch.

Done and done. :slight_smile:

Also tested new cable and port with windows laptop… Working perfectly.

No difference with Pi tho.

Tried connecting directly to the router then? It’s almost certainly a local issue. I’m not sure we’ve ever seen this report.

I originally had it connected as follows:

Pi3 - Switch - WAN router.

I bypassed the switch completely, so connection was Pi3 - WAN router directly.

No luck. Same symptoms.

I’ve exhausted my troubleshooting abilities, if nobody can think of anything else, it might be a faulty ethernet port or controller.

Might try a re-install at this point as well.

1 Like

Thanks… I’ll try that, if it doesn’t work, I’ll try get a warranty replacement.

Think your on the right path might be a defunct rpi

Ok. Have found the problem.

My router is situated around 15 m away, connected via ethernet cabling, so cable run is around 25m. RPi seems to not have enough power to connect reliably over this cable distance. I’ve just reconnected, adding a small powered switch with a short cable to the RPi. Then longer cable now runs from the switch to the router.

Working fine now. A 25m ethernet cable doesn’t seem that long to me, but the RPi doesn’t like it!

Did you check ethtool eth0 to see if there is actually a link?
Got a vero2 but it should look like this:
osmc@vero2:~$ ethtool eth0
Settings for eth0:
Supported ports: [ TP AUI BNC MII FIBRE ]
Supported link modes: 10baseT/Half 10baseT/Full
100baseT/Half 100baseT/Full
Supported pause frame use: No
Supports auto-negotiation: Yes
Advertised link modes: 10baseT/Half 10baseT/Full
100baseT/Half 100baseT/Full
Advertised pause frame use: No
Advertised auto-negotiation: Yes
Speed: 100Mb/s
Duplex: Full
Port: MII
Transceiver: external
Auto-negotiation: on
Cannot get wake-on-lan settings: Operation not permitted
Link detected: yes

Link needs to be detected… and the speed has to be shown.
PS: Sorry - code display doesn’t work.

I didn’t bother. Problem was (in retrospect) obviously the cable length.