No wired internet connection after installing updates

My vero installed fine; wired networking was ok. After I installed all updates it cannot get a wired network connection anymore.
Tried a few things:
Toggling the adapter – no change
Toggling power – no change
Connecting directly to router, bypassing 2 switches – no change

I guess it tries to use dhcp and it doesn’t succeed in getting an ip address (in time). I cannot find any settings to try a fixed ip.

Wireless networking works fine. My pi running osmc works fine using dhcp using the same utp cables …

Any suggestions are welcome …

You can configure a static IP in wired network settings - choose the option just above the IP address in the wired panel and you can then edit IP addresses etc and press apply.

Before trying this however I would shut down, unplug the power and reconnect the power. I’m not aware of any changes in networking in the updates that would affect Ethernet…

I go to My OSMC, and then to the network options symbol, then I choose “wired”:
I only have 1 option:“Enable adapter”. At the bottom of the screen it says: “Status: No wired connection”.
That’s it, no panel, no more options …

You haven’t pushed enough buttons - in that state you can persuade another display. I don’t remember exactly how, but did it a couple of days ago.


Before you ran the update did you have a wireless connection configured as well as Ethernet, or did you not add that until after Ethernet stopped working ?

By default connman (our network manager) is configured to only allow one network connection to be active at a time, (wired or wireless) however that decision was made some time ago before the current networking GUI was designed and on reflection it may not be the best choice. In fact in the current test version of the networking package we have reversed this change.

Could you try editing /etc/connman.conf:

sudo nano /etc/connman.conf

Edit the line that says:


Change true to false, save (ctrl x) then reboot, and see if Ethernet is working again ?

If so Ethernet not showing up was due to having an active Wireless connection.

Thanks for the help, but no success …
I tried all buttons on the remote, but I don’t get a panel. (I do see the panels in the wireless and Bluetooth screens).
I also power cycled both the vero and the router once more just to be sure … No change

I’ll give that a try dbmandrake. It will take me some time (have to install ssh on my laptop).
Reading your post made me remember that I initially powered up the vero with the utp cable disconnected. Maybe that triggered the networking glitch.
I"ll report back later.
Thanks so far.

If you can plug a keyboard into the Vero you can edit it from there - choose to exit from kodi, (not reboot or shutdown) then press ESC when the splash screen appears, you can log in there as osmc/osmc and make the change.

Let me know if it solves your problem. The other thing you could try doing is specifically disabling wireless or disconnecting the wireless connection then see if Ethernet shows up again.

I don’t have a Bluetooth or USB keyboard available. (Would the vero support a USB keyboard out of the box?).

Switching off the wireless adapter I already tried. No success. I"ll go for winscp and come back

USB keyboards are supported out of the box, Bluetooth keyboards with the latest update. (But you need to pair before you can use it of course)

I put SingleConnectTechnology to false and power cycled again. No change, still no panel shown.
I just read back the setting to make sure it was stored (and it was).
I also see the setting PreferredConnectedTechnology=ethernet,wifi. Is it safe to try to remove wifi, or will I lock myself out of the box without keyboard?

I"ll get myself a USB keyboard tomorrow by the way.

Every time I toggle the wifi adapter the vero forgets my wifi password … Small inconvenience.

Yes that is a known issue with the networking GUI - the system does remember the password but the GUI does not.

Regarding your Ethernet problem can you try the following steps for me please, so we can get some detailed debugging information:

  1. While connected on Wifi, check for updates - there should be at least a couple which install including one called armv7-network-osmc.
  2. Enable debugging in Kodi under Settings->System.
  3. Make sure your Ethernet cable is connected then reboot.
  4. Try to go into the wired page in Networking settings in OSMC settings.
  5. Assuming that you still see the network interface is not showing up properly, then please go into the Log uploader in OSMC settings, choose to upload all logs.
  6. Paste the URL displayed here.


Sorry, but I could not post earlier. There seems to be a limit on “posts per day” for new forum members … I had to wait a few hours…
I followed you instruction and downloaded and installed the updates; switched on the logging and rebooted. Still no panel in wired networking. I uploaded the logfile.

Thanks a lot for your help so far (and I got myself a USB keyboard. Works well!!).


I have (hopefully – Discourse is newfangled to me) lifted your posts per day rights.

I will look into this issue myself shortly


1 Like

Thanks Sam. It’s no big deal. I understand spam protection is a must have.
If I can provide anymore info, just let me know.
(and take your time. I guess these must be busy days for you)

I painted myself into another networking corner. I post it in this thread because it’s probably related to the issue above of not being able to switch on wired networking (but it can also be an independent issue):
1 I go into network setup
2 I switch off both wired and wireless networking
3 I switch on Bluetooth
4 after a refresh I see my iPad in the right panel; I don’t see the Vero as a Bluetooth device on my iPad though
5 I select the iPad in the right panel
6 the vero shows a dialog asking confirmation to connect. I confirm.
7 the iPad asks if a code is displayed on device [mac address of the Vero]
8 there is no code displayed on the vero, but I confirm on the iPad nonetheless.
9 the connection setup on the iPad fails (don’t know why)
10 the vero is now locked into the Bluetooth setup screen. I can still move the cursor around and toggle the boxes on screen. I can also navigate the left menu and go to wired or wireless, but the Bluetooth setup panels keep being displayed. There is no way out of the Bluetooth setup screen anymore (not with the remote, not with the keyboard).
Only a power cycle gets me to the home screen again.

I imaged another SD card, run all updates and now wired networking via DHCP is fine (so that completely rules out my cabling, router, etc).
I think I triggered the faulty networking behaviour by initially booting the Vero with no UTP cable connected.
In case you still want to look into the issue and maybe need more info I’ll keep my original SD card, but for me the issue is solved. Can imagine you stilll want to look into it, because other users might stumble on it as well.