No wireless option-Vero 4K

Hi dear friends. After a great experience with Vero 4K (since september) suddenly today i had no wifi connection. I went to ‘‘osmc-network’’ and the option ‘‘wireless’’ under ‘‘wired’’ didn’t even show up!! Thats very strange imo. Tried everything. Reboots, unplug/plug, restart modem and other stuff. Finally i made a clean reinstall osmc with an sd card(i downloaded the last img) and still nothing changed. I don’t have wireless option in network section.

Hi,

I would try this, you will need to access the command line:

https://osmc.tv/wiki/general/accessing-the-command-line/

issue the following commands:

sudo rm-rf /var/lib/connman/ethernet*

&

sudo rm-rf /var/lib/connman/wifi*

and reboot or sudo reboot 0

The options should have returned and should be able to connect to your wifi.

Thanks Tom.

1 Like

The problem is i can’t connect with SSH cause i dont have the ip right? And locally i can’t connect. My tv is a bit old and osmc logo doesn’t even appear so i can press esc and log in.

Can you fix up a wired connection temporarily?

Can you temporarily connect it wired?

You can restart (don’t reboot) Kodi from the menu, and then you have about 10 seconds before Kodi starts again to press ESC and access the command line.

No i can’t :frowning:

Can’t what? Connect wired? Restart Kodi and press ESC?

EDIT: Opps I see, @grahamh and I suggested wired at the same time…

Try my other suggestion to restart Kodi.

he was replying to me, i think

Sorry. I can’t try wired right now. And when i restart kodi and press esc nth shows up. Just reboots after few sec into osmc.

If you have an old TV, chances are the command prompt is off the screen because of overscan. Is there a setting to turn overscan off? Should be called 1-1 or Just scan or something.

I didnt find this setting at TV. Anyway it’s a bit late and i have work at morning.I will try for it tomorrow and i will talk to you again ok guys? Hope we can solve it.

Go to osmc.tv/download and reinstall (easiest option)

Sam

Hi guys sorry for late feedback, i was busy. I finally figured it out. Made a wired connection to vero 4K and then i connected through SSH from my android device(no network on my desktop). I gave the commands:
sudo apt-get update &
sudo apt-get dist-upgrade and everything was finally normal. Wireless came back and worked great.

These commands didn’t work for me though:
sudo rm-rf /var/lib/connman/ethernet*
&
sudo rm-rf /var/lib/connman/wifi*
Thanks for your help guys.

1 Like

If that’s what you typed in exactly, you missed a space:

sudo rm -rf /var/lib/connman/ethernet*
1 Like

Yeah mate i know. i typed the correct command. But unfortunately it happened again. i was about to mark this problem as solved but… After 5 days of thinks run smooth and without any problems few minutes ago i was about to watch a show. Again no wifi and the wireless option dissapeared. It’s hard for me to go again with wire and solve it (same way as before i guess) and it will be obviously temporary. Something is wrong with firmware? And i have reinstalled osmc…

Can you upload the output of dmesg?

I think your device may be faulty if the WiFi is intermittent.

I guess i can run command with ssh? It will be hard for me cause if i tranfer my modem to Vero4K(so i can make wire connection) only way to access it is with ssh app from my android, as i did before to solve my problem.

dmesg | paste-log will give you a URL.

Sam

1 Like

I will try for it or i 'll go to another pc. I 'll let you know. Thanks for fast response Sam.

1 Like

Hey Sam. Here you are mate:
https://paste.osmc.tv/ulobohuyib