Noob install help with quirky monitor

Hello! New to Pi, new to OSMC. Here’s my situation:

I’ve installed latest boot image from my PC using etcher.

I’ve got a silly monitor hooked up to the pi:

There are some specific Pi settings I’ve found to get this fella working with my Pi 4 (as currently when I power up, it just shows a black screen):

max_framebuffer_height=1920
max_usb_current=1
config_hdmi_boost=10
hdmi_group=2
hdmi_force_hotplug=1
hdmi_mode=87
hdmi_timings=1080 1 100 20 170 1200 1 6 3 3 0 0 0 90 0 147800000 3

My question is this: how do I set these values? The file that I downloaded to flash from was compressed, I figure I don’t want to touch that – then after flashing the SD is unrecognizeable on my PC so I can’t make any adjustments to whatever is on the card. Is etcher formatting it wrong?

Thank you for any advice! Cheers.

I would suggest booting and installing OSMC on a normal TV / display, then once it’s set up, editing /boot/config-user.txt to set your values.

That’s a good idea. That’s one of the beauties of the Pi isn’t it. Ultra portable!

Glad to know I didn’t accidentally nuke the boot card - I was thinking it odd that neither windows nor ubuntu would recognize the drive after formatting.

They should recognise the filesystem. After imaging all you will have is a single FAT32 filesystem.

The ext4 partition is created after booting.

I am able to SSH into the pi and manually edit the boot/config-user.txt, so that seems like an important step!

Unfortunately when I boot, the screen goes a little berzerk then goes back to black - I’m assuming there’s a setting it doesn’t like. Do you recommend modifying values in [all] section of the /boot/config.txt, or should I overwrite them with values in the config-user file?

Also - is there documentation somewhere that I can look for what settings might be useful for me? Seems like I need to at least rotate my screen 90 degrees, which is weird.

Thanks so much for you help so far!


Where did you get that modeline from? IIRC it specifies a 1080x1200 resolution which is a kinda portrait mode.

That’s a very good point! I got that config from their ‘official’ website, but that’s a good idea to tweak those numbers. Thanks!

EDIT: not able to get any meaningful change out of modifying any of these config values - if there’s some documentation on them I’d love to see it. Thanks y’all.

Where is their website? Your original link has gone AWOL.

Oh wow they seem to have nuked the page between yesterday and today. That’s fun, haha!

In my research on this I’ve discovered that my issue is not related to osmc at all, and that even in just trying to install PiOS or Ubuntu, the screen doesn’t like the config I supplied above (which I found here: CARY WORKS X KBDFANS VIEWEDGE - Google Drive )

Also I’ve found all of the documentation I’m seeking at raspberrypi.com in their docs - I foolishly thought these were osmc related. Yep I’m the new guy haha

I’ll keep hunting, and will try to contact the creators of this monitor.

Thanks again, y’all.

The hdmi_timings for the RPi3 makes a bit more sense. No idea why they would be different. But try this slight modification:

hdmi_timings=1080 1 100 5 170 1200 0 6 3 3 0 0 0 90 0 147800000 3

Do they publish a modeline for linux/ubuntu?

All I’ve been able to find is this generic config.txt file in this shared drive.
Switching out the timings to the rpi3 version when booting a ubuntu build results in a black screen, whereas the previous timings defined for the 4 at least showed a some fuzzy stuff on the top :laughing:

I’ve reached out to the person who owns this drive link - I’ll see if he responds!