Not able to add FTP as video source

After updating to Kodi 18 RC5 (necessary to get Netflix working) I am facing several issues that I want to address separately.

This problem here is concerning the seemingly inability to add an FTP as a video source. I remember getting it working when I got my device (VERO4K) but now that does not work anymore.

After attempting to add my FTP server (which is my router running OpenWRT and vsftpd) via the menu entry, I get the error that no network connection can be established (and I get asked whether I still want to add the source).

Checking my logfile, I see

20:25:40.150 T:4071764576   DEBUG: ------ Window Deinit (DialogSettings.xml) ------
20:25:40.150 T:4071764576   DEBUG: FreeVisualisation() done
20:25:40.151 T:4071764576   DEBUG: CurlFile::Open(0xffe7c440) ftp://USERNAME:PASSWORD@router:21/nas/cloudspace_daniel/Movies/
20:25:40.151 T:4071764576    INFO: easy_acquire - Created session to ftp://router
20:25:40.263 T:4071764576   ERROR: CCurlFile::FillBuffer - Failed: Access denied to remote resource(9)
20:25:40.263 T:4071764576   ERROR: CCurlFile::Open failed with code 550 for ftp://USERNAME:PASSWORD@router:21/nas/cloudspace_daniel/Movies/:
20:25:40.263 T:4071764576   ERROR: GetDirectory - Error getting ftp://USERNAME:PASSWORD@router:21//nas/cloudspace_daniel/Movies
20:25:40.263 T:4071764576   DEBUG: ------ Window Init (DialogConfirm.xml) ------
20:25:40.263 T:4071764576    INFO: Loading skin file: DialogConfirm.xml, load type: KEEP_IN_MEMORY
20:26:10.518 T:4071764576    INFO: CheckIdle - Closing session to ftp://router (easy=0xaeb39600, multi=0xad538910)

I’m able to connect to the folder via FTP client from my phone.
Any hints?

If it’s a Kodi 18 issue, you’ll need to rely on others to help you, but we can at least test if curl/ftp is working on your box. Choose a small file in the Movies directory of your FTP server and try to copy it across using the command from the above log snippet:

curl ftp://USERNAME:PASSWORD@router:21//nas/cloudspace_daniel/Movies/<small-file> -o /dev/null

(Choose the file name and change username / password, as appropriate)

Hey! So I tried your suggestion and that worked. I also manually inserted the address into the network drive ‘connection string’ and that didn’t really work.

Do you mean the IP address? Could you also be a bit more specific about what you mean by “didn’t really work”?

Please also post full logs, since log snippets can sometimes obscure as much as they reveal.

No, if I

  • go to my Video entry in the main menu
  • edit the ‘file source’ which is the network drive (called NAS here)
    then NAS has one path (the presumable FTP server which I tried to configure and which failed to connect), which is the ftp string you mentioned above. I can modify this to ftp://USERNAME:PASSWORD@router:21//nas/cloudspace_daniel/Movies but no luck, I still get
22:32:43.922 T:3791479536   ERROR: CCurlFile::FillBuffer - Failed: Access denied to remote resource(9)
22:32:43.922 T:3791479536   ERROR: CCurlFile::Open failed with code 550 for ftp://USERNAME:PASSWORD@router:21/nas/cloudspace_daniel/Movies/:
22:32:43.922 T:3791479536   ERROR: GetDirectory - Error getting ftp://USERNAME:PASSWORD@router:21//nas/cloudspace_daniel/Movies/
22:32:43.997 T:4067787360   ERROR: CGUIMediaWindow::GetDirectory(ftp://USERNAME:PASSWORD@router:21//nas/cloudspace_daniel/Movies/) failed

What additional log do you need? From boot? With or without debug? Still new to the forum.

You should try using the IP address instead of the network name “router”

That didn’t change anything either. Although that would have wondered me, it looks like the FTP string is generated and then sent somehow - and hostnames are also resolved in router itself.
Although I’m a little confused with this rights issue - the osmc user seems to have no trouble otherwise. What happens “between” CCurlFile and vsftpd?

Full debug logs, please.

Depending on the used skin you have to set the settings-level to standard or higher, in summary:

  • enable debug logging at settings->system->logging

  • reboot the OSMC device

  • reproduce the issue

  • upload the log set either using the Log Uploader method within the My OSMC menu in the GUI or the ssh method invoking command grab-logs -A

  • publish the provided URL from the log set upload, here

OSMC skin screenshot: