Not able to play a .m3u that works like a charm in VLC


I am trying to play a .m3u in Kodi that works like a charm in VLC:

I have tried putting it in a text file and rename the file extenstion to .strm and also tried to play it through the IPTV.Simple PVR add-on without success.

Any idea??

Well the m3u file doesn’t include the URL :wink:
So adding before the playlist entries works.

Alternatively putting “” into a .strm file also works.

I don’t know why but putting “” into a .strm file DOES NOT work for me (Rasp b+, OSMC 17.5)

Did you just put that in as is? I just tried it and it is working

osmc@osmc:~$ cat /mnt/server/video/mono.strm

1 Like

Exactly like you…

Enable debug logging and upload logs to find out whats wrong

Hope it is ok because it is my first time uploading a log…
I think everything starts at line 236

Please take into account that there is neither audio nor video playing it with VideoPlayer and only audio with PAPlayer


Does it play if you disable Allow hardware acceleration?

Thanks Tom.

1 Like

Yes, it does!! (disabling Allow hardware acceleration for OMXPlayer)

What are the pros and cons of disabling it??


The stream will be now processed using cpu, not the gpu. You could try enabling MMAL and see if the stream plays.

If not I would re-enable when not watching this stream.

Thanks Tom.