Not booting after December update

Okay

Can you revert the kernel back and try adding dtoverlay=mmc to config.txt?

Also please try the loglevel and splash changes suggested above by editing cmdline.txt

OK
Back to 4.3.3-1-osmc then

quiet remove loglevel=7

Reboot and black screen with only one line : Welcome to Open Source media Center!

I stay on that state before going to grab some logs just in case you want to test something else before. Tell me.

EDIT:
I forgot to mention that of course I change the dtoverlay too to get that at the end
dtoverlay=lirc-rpi:gpio_out_pin=17,gpio_in_pin=18 disable_overscan=1 over_voltage=0 over_voltage_sdram=0 force_turbo=0 disable_splash=1 core_freq=450 initial_turbo=0 start_x=1 max_usb_current=1 sdtv_aspect=1 gpu_mem_1024=256 arm_freq=900 sdram_freq=450 hdmi_ignore_cec_init=1 dtoverlay=mmc
M.
PS: to let you know, my mini keyboard has no Function keys so I can’t say if the ALT+F2 is working or not.

I think that this issue is related to the fact that the Pi foundation has changed the default SD card driver to ‘SDHost’. It would be good to know which SD cards people are using, as there are still some compatibility issues.

I’d be interested in knowing if this resolves the issue:

Download this file: https://github.com/raspberrypi/firmware/raw/master/boot/overlays/mmc-overlay.dtb and place it in /boot/overlays. This can be done from a PC or Mac.

Edit config.txt, and add the following:

dtoverlay=mmc

Sam

6 Likes

(first of all: right now I am at work and I can’t help much with any test)
After several attempts, I also tried a fresh install, and once I did apt-get dist-upgrade, the system didn’t boot any longer.
I restored /boot and it started working again.
As of this I am confident that the package that we are getting is broken, and (believe me) right now none of the OSMC on the PI2 around the world is working :cry:
At this point, if you developers say “we tested it, and it worked for us” the question is:

  • where do you grab the package? Are you using our same source to install the package?
  • did at any point the package become corrupted, or messed up with a wrong package?

Funny my pi2 and i got 2 of em on Jarvis running on December updates and no issues at all

question is what differs between your installation and my installation since yours doesn’t work

My RPi1 and 2 are working… so not all users are affected!

sqlite> SELECT COUNT(DISTINCT dbusID) FROM online WHERE version = "2015.12-1" AND deviceID="rbp2";
19336

It appears that 19,000+ Raspberry Pi 2 have been updated in the past 24 hours and are working OK, or they would not be contacting the update server.

Your issue is almost certainly related to your SD card, and I have posted what I believe to be a solution above.

We got it from the same APT server you did

No. The packages have checksums to prevent this.

Sam

I’ve also tried a fresh install, thru osmcinstaller from Linux.
A very normal installation I would say :grinning:
Perhaps, as Sam wrote (and makes sense) the only thing that makes the difference is the SD.

You need this from good updates as well or?

and power supplies they can also cause issues but in this case its probly sd

No – I just need an affected user to try out my solution above and confirm it as fixed or not.

1 Like

not working for me.

UPDATE: i’m stupid. copied into the wrong file.

:clap: :clap:

You did it.

I add the file with the dtoverlay directive and works like a charm.

For information, I have a Transcend TS16GUSDHC10E (http://www.amazon.fr/gp/product/B008UR8TZ8?psc=1&redirect=true&ref_=oh_aui_detailpage_o06_s00)

Need something else to better understanding? I stay on that state until further notice or additional testing.

EDIT:
I saw @grey message. I double checked. I am using the 4.3.3-1-osmc kernel (2015.12-1) running Kodi 15.2 Compiled Nov 22 2015).

Thanks for confirming.

The SDHost SD card driver is relatively new, but it works well with most cards.

I personally never recommend Transcend or Kingston SD cards, as they don’t have good 4K random write speeds and they seem to give users the most hassle.

I’ll see how SDHost holds up, if the issue is very widespread (although it does not seem to be), then we can always revert to the MMC SD card driver by default.

Cheers

Sam

No. The packages have checksums to prevent this.

Sam:
[/quote]

well, a good checksum against a broken package, would give a broken package to everybody, with a good checksum :grinning: This is what I meant… not a broken download, that would not match the checksum.

But now I tend to believe that the SD that we are using matters…

I have a 16 GB card (I don’t remember the manufacturer)

The package is not broken

OK perfect. I say like this for the moment.
Should I take a special care about next update? Can I put back the quiet and remove the loglevel or do you want me to stay like this for a moment/additional tests?

M.

No care needs to be taken for the next update. You can restore cmdline.txt as before

I got my SD card readable again (by making it read only and then writable again - no idea why it worked but it did) and then tried this. Works for me and now booting fine. Nice one, thanks a lot.

Weird I got these working without any problems…
Transcend Ultimate 600x 8GB microSDHC card (TS8GUSDHC10U1)
Transcend Premium 8GB microSDHC card (TS8GUSDC10)[quote=“sam_nazarko, post:62, topic:11385”]
I personally never recommend Transcend or Kingston SD cards, as they don’t have good 4K random write speeds and they seem to give users the most hassle.
[/quote]
I’m on here for quite some years and have never heard any negative things about Transcend I must say…