Not booting after December update

If someone has a second device, then try removing the SD card and putting it in that. If it still doesn’t boot, then it would be good if you could make a backup of the SD card, upload it to Dropbox and PM me a link so I can replicate your setup.

Can you try downgrading your kernel to the previous one. Make sure you have recovery in your cmdline.txt and boot to the recovery console again. Then run the following command to find the kernel versions you have installed:

ls -al /boot/vmlinuz*

You will see vmlinuz-4.3.3-1-osmc which is the December Pi1/2 kernel, and one (possibly more) older versions. Run the following command but replacing the version number (if different) with the older version you have: (it depends on what version you were on before updating)

dpkg-reconfigure rbp2-image-4.3.0-10-osmc

(Note anyone else trying this on a Pi 1 please replace rbp2 with rbp1 in the command)

After that remove recovery from cmdline.txt - you can do this directly from where you are with:

nano /boot/cmdline.txt

When finished type exit to reboot. Let us know the outcome.

No problems on my RPi2, i’ll upgrade my RPi1 upstairs to see if that one has a problem, if so… I could help as well

edit: that one updated perfectly as well… sorry!

1 Like

Failing that, edit cmdline.txt:

Remove quiet
Add loglevel=7

Show us what you see

Nope. Nothing

Do you get the same issue if you use the OSMC installer instead of the noobs installer ? Which version of the noobs installer did you use ?

BTW a problem affecting a small number of users does not make something “fubar” :wink:


As requested. I found the 4.3.0-10 (I was up-to-date so no surprise).

After the dpkg-reconfigure rbp2-image-4.3.0-10-osmc and the removal of recovery, normal boot again.

To be complete, only keyboard on at first boot. I exited. Put back HDD and network and works as before.

Tell me how I can help to find the issue.

EDIT: To be complete, I check SSH back, drive HDD OK. In summary, everything is back to normal with that procedure. If you need something from this state, it’s far more easy now: I have a real keyboard and full ssh access (instead of a mini USB remote keyboard who drove me crazy to find that damned / :wink:) .

1 Like

A post was split to a new topic: SD card unreadable after update


Can you revert the kernel back and try adding dtoverlay=mmc to config.txt?

Also please try the loglevel and splash changes suggested above by editing cmdline.txt

Back to 4.3.3-1-osmc then

quiet remove loglevel=7

Reboot and black screen with only one line : Welcome to Open Source media Center!

I stay on that state before going to grab some logs just in case you want to test something else before. Tell me.

I forgot to mention that of course I change the dtoverlay too to get that at the end
dtoverlay=lirc-rpi:gpio_out_pin=17,gpio_in_pin=18 disable_overscan=1 over_voltage=0 over_voltage_sdram=0 force_turbo=0 disable_splash=1 core_freq=450 initial_turbo=0 start_x=1 max_usb_current=1 sdtv_aspect=1 gpu_mem_1024=256 arm_freq=900 sdram_freq=450 hdmi_ignore_cec_init=1 dtoverlay=mmc
PS: to let you know, my mini keyboard has no Function keys so I can’t say if the ALT+F2 is working or not.

I think that this issue is related to the fact that the Pi foundation has changed the default SD card driver to ‘SDHost’. It would be good to know which SD cards people are using, as there are still some compatibility issues.

I’d be interested in knowing if this resolves the issue:

Download this file: and place it in /boot/overlays. This can be done from a PC or Mac.

Edit config.txt, and add the following:




(first of all: right now I am at work and I can’t help much with any test)
After several attempts, I also tried a fresh install, and once I did apt-get dist-upgrade, the system didn’t boot any longer.
I restored /boot and it started working again.
As of this I am confident that the package that we are getting is broken, and (believe me) right now none of the OSMC on the PI2 around the world is working :cry:
At this point, if you developers say “we tested it, and it worked for us” the question is:

  • where do you grab the package? Are you using our same source to install the package?
  • did at any point the package become corrupted, or messed up with a wrong package?

Funny my pi2 and i got 2 of em on Jarvis running on December updates and no issues at all

question is what differs between your installation and my installation since yours doesn’t work

My RPi1 and 2 are working… so not all users are affected!

sqlite> SELECT COUNT(DISTINCT dbusID) FROM online WHERE version = "2015.12-1" AND deviceID="rbp2";

It appears that 19,000+ Raspberry Pi 2 have been updated in the past 24 hours and are working OK, or they would not be contacting the update server.

Your issue is almost certainly related to your SD card, and I have posted what I believe to be a solution above.

We got it from the same APT server you did

No. The packages have checksums to prevent this.


I’ve also tried a fresh install, thru osmcinstaller from Linux.
A very normal installation I would say :grinning:
Perhaps, as Sam wrote (and makes sense) the only thing that makes the difference is the SD.

You need this from good updates as well or?

and power supplies they can also cause issues but in this case its probly sd

No – I just need an affected user to try out my solution above and confirm it as fixed or not.

1 Like

not working for me.

UPDATE: i’m stupid. copied into the wrong file.