Not booting after December update

:clap: :clap:

You did it.

I add the file with the dtoverlay directive and works like a charm.

For information, I have a Transcend TS16GUSDHC10E (http://www.amazon.fr/gp/product/B008UR8TZ8?psc=1&redirect=true&ref_=oh_aui_detailpage_o06_s00)

Need something else to better understanding? I stay on that state until further notice or additional testing.

EDIT:
I saw @grey message. I double checked. I am using the 4.3.3-1-osmc kernel (2015.12-1) running Kodi 15.2 Compiled Nov 22 2015).

Thanks for confirming.

The SDHost SD card driver is relatively new, but it works well with most cards.

I personally never recommend Transcend or Kingston SD cards, as they don’t have good 4K random write speeds and they seem to give users the most hassle.

I’ll see how SDHost holds up, if the issue is very widespread (although it does not seem to be), then we can always revert to the MMC SD card driver by default.

Cheers

Sam

No. The packages have checksums to prevent this.

Sam:
[/quote]

well, a good checksum against a broken package, would give a broken package to everybody, with a good checksum :grinning: This is what I meant… not a broken download, that would not match the checksum.

But now I tend to believe that the SD that we are using matters…

I have a 16 GB card (I don’t remember the manufacturer)

The package is not broken

OK perfect. I say like this for the moment.
Should I take a special care about next update? Can I put back the quiet and remove the loglevel or do you want me to stay like this for a moment/additional tests?

M.

No care needs to be taken for the next update. You can restore cmdline.txt as before

I got my SD card readable again (by making it read only and then writable again - no idea why it worked but it did) and then tried this. Works for me and now booting fine. Nice one, thanks a lot.

Weird I got these working without any problems…
Transcend Ultimate 600x 8GB microSDHC card (TS8GUSDHC10U1)
Transcend Premium 8GB microSDHC card (TS8GUSDC10)[quote=“sam_nazarko, post:62, topic:11385”]
I personally never recommend Transcend or Kingston SD cards, as they don’t have good 4K random write speeds and they seem to give users the most hassle.
[/quote]
I’m on here for quite some years and have never heard any negative things about Transcend I must say…

mine is a 16Gb Transcend Premium 300x.
put the “dtoverlay=mmc” and “loglevel=7” to the txt file, downloaded the file and copied it to overlays directory.

still, all i got is “Welcome to Open Source Media Center!” and that’s it…

dtoverlay=mmc goes in config.txt not cmdline.txt

loglevel=7 goes in cmdline.txt but is only for displaying extra diagnostics and is not part of the workaround, so isn’t needed if dtoverlay solves the issue.

damn, my bad.

give me 2 minutes and report back.

UPDATE: it’s ALIVE!

1 Like

This is part of the problem as well. Some people will have an 8GB card of XYZ brand and it will work, and for some it won’t. The problem is that while the outward appearance or even model number of the card may be the same, the internals may not. This makes it even more difficult to discern problems.

I am confident enough that I would bet that every affected user has either a Transcend or Kingston SD card. They used to be good, but I noticed over time new SD cards would have a severe deterioration in random 4K write speeds, despite the model number and outer markings on the card being the same.

Another user has asked for my opinions on SD cards, which I have written about here: SDCard Choice - #2 by sam_nazarko

If you keep dtoverlay=mmc in your config.txt, your system will be preserved across updates, but you will not be enjoying the benefits of the new SDHost driver. It may be a good idea next update to try removing the line and seeing if the system still boots, as there may be some improvements to the driver that make your card usable again.

I will leave this thread open for a brief while until closing it as resolved.

Sam

1 Like

I am using a Samsung SD card ( the one that came with the PI 2). I have this issue as well. Will try the other SD driver when I’m wearing pants.

1 Like

Is it a Samsung Evo? @DBMandrake had an issue with a Samsung card and sent it to the Raspberry Pi foundation as it did not boot for him.

The card I had issues with was a Samsung 32GB class 10 but it was made a year before the evo models came out. I have two Samsung evo cards and they are not affected by this issue.

I can’t wait to come back home and try this workaround!
Thank you, Sam

It isn’t an EVO, no. It works without the update. I’m guessing it’s related to the driver. Just about to try your suggested fix.

Unless I did something incorrectly, changing drivers didn’t fix the issue. I’ve downloaded mmc-overlay.dtb and placed it in a new folder on the SD called “overlays”. I created the config.txt file with the first and only line: “dtoverlay=mmc” . Still frozen at the boot screen with no ssh access.

There should already be a folder called overlays on the fat partition with other dtb files in it, and there should already be a config.txt file with many lines in it in the root directory of the fat partition… are you saying you don’t have either of these ?

What do you have on your fat partition ? Please show us a directory listing including file sizes and dates for the fat partition including the overlay folder.

I’m an idiot. It’s a noobs install. I’ll need to install linux.